Bug 918767 - Update of kernel causes external display to stop working on MacBook
Summary: Update of kernel causes external display to stop working on MacBook
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-06 20:10 UTC by W. Michael Petullo
Modified: 2014-06-18 13:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-18 13:58:37 UTC
Type: Bug


Attachments (Terms of Use)
Output from dmesg on Linux 3.8.7 (213.87 KB, text/plain)
2013-04-16 21:15 UTC, W. Michael Petullo
no flags Details
Result of execution startx (15.76 KB, text/plain)
2014-03-03 21:07 UTC, peter
no flags Details
Output from dmesg on Linux 3.13.6, following use of xrandr (67.05 KB, text/plain)
2014-03-24 00:44 UTC, W. Michael Petullo
no flags Details

Description W. Michael Petullo 2013-03-06 20:10:08 UTC
Description of problem:
I recently updated my MacBook's kernel to 3.8.1-201.fc18.x86_64 and found that Fedora 18 no longer detects my external monitor.

Version-Release number of selected component (if applicable):
kernel-3.8.1-201.fc18.x86_64
xorg-x11-drv-nouveau-1.0.6-1.fc18.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade Fedora 18 to kernel-3.8.1-201.fc18.x86_64
2. Boot the new kernel
3. Connect an external DVI monitor via an Apple Mini DisplayPort adapter
  
Actual results:
Fedora does not detect the external monitor.

Expected results:
Rebooting using kernel-3.7.9-205.fc18.x86_64 fixes things, that is, Fedora 18 detects the external monitor when using this version.

Additional info:
My laptop is a MacBook5,1.
lspci reports: VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400M] (rev b1)

Comment 1 Josh Boyer 2013-04-16 19:32:49 UTC
Is this working with 3.8.7?  If not, could you post dmesg output from 3.7.9 and 3.8.7?

Comment 2 W. Michael Petullo 2013-04-16 21:14:03 UTC
3.8.7 does not work either.

Comment 3 W. Michael Petullo 2013-04-16 21:15:15 UTC
Created attachment 736549 [details]
Output from dmesg on Linux 3.8.7

Comment 4 W. Michael Petullo 2013-06-19 13:28:35 UTC
I am also having this problem with Fedora 19:

kernel-3.9.6-301.fc19.x86_64
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64

Comment 5 Josh Boyer 2013-09-18 20:36:20 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 6 W. Michael Petullo 2013-09-19 17:01:52 UTC
This is still a problem with kernel-3.11.1-200.fc19.x86_64.

Comment 7 W. Michael Petullo 2013-11-22 13:27:44 UTC
It seems that kernel-3.11.8-300.fc20.x86_64 on Fedora 20 still has a problem. Here when I plug in an external monitor, both screens go blank.

Comment 8 W. Michael Petullo 2013-12-10 03:56:02 UTC
Here are some more details about the current status:

1. "gnome-control-center display" states "Could not get screen information".

2. Booting the laptop with an HDMI television connected using a Mini-DP adapter works---the laptop uses the television as a second display.

3. Booting the laptop with a VGA monitor connected using a Mini-DP adapter causes the main screen to go blank after GRUB loads the kernel (the VGA screen never displays anything).

4. Booting the laptop, later connecting the VGA monitor, and then running "xrandr --output LVDS-1 --mode 1280x800 --output DP-1 --mode 1900x1080" causes the main display to go blank (the VGA monitor never displays anything).

Comment 9 Justin M. Forbes 2014-02-24 14:00:51 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 10 W. Michael Petullo 2014-02-24 15:34:40 UTC
No change with 3.13.3-201.fc20.x86_64.

Comment 11 peter 2014-02-26 21:27:40 UTC
The bug is still present in kernel 3.13.4-200.fc20.x86_64. (AMD A6-3500 APU Radeon HD Graphics)

Comment 12 peter 2014-03-03 10:54:12 UTC
No change with 3.13.5-200! -now I have three not working kernel in my grub.cfg! My computer doesn't start any longer! I have made the update late at night. Today I'm doing a downgrade to 3.12.

Comment 13 peter 2014-03-03 21:07:39 UTC
Created attachment 870128 [details]
Result of execution startx

Comment 14 NM 2014-03-08 16:48:10 UTC
Same here. Forced to use 3.12.10 kernel.

Comment 15 peter 2014-03-08 20:00:38 UTC
I'm using the proprietary amd-catalyst driver now, it works with 3.13.5-200 too. Sorry.

Comment 16 W. Michael Petullo 2014-03-24 00:44:17 UTC
Created attachment 877911 [details]
Output from dmesg on Linux 3.13.6, following use of xrandr

Comment 17 W. Michael Petullo 2014-03-24 00:45:26 UTC
This problems described by peter and NM do not seem to be due to the same bug as was originally reported.

Comment 18 W. Michael Petullo 2014-03-24 01:08:15 UTC
Some of the lines in my latest dmesg log resemble those reported at: https://bugs.freedesktop.org/show_bug.cgi?id=63135

Comment 19 peter 2014-03-24 17:55:49 UTC
Sorry if I was wrong, the symptom appeared to be the same. I'm not affected because I switched to nVidia. I need the card for a project. I can be removed from the cc list.

Comment 20 Justin M. Forbes 2014-05-21 19:40:11 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.14.4-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 21 Josh Boyer 2014-06-18 13:58:37 UTC
This bug is ancient and the relevant details are stale.  We're going to close this out.  If you're still having issues with 3.14.y or newer, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.