Bug 918783 - RFE: log rotate for all cartridges
RFE: log rotate for all cartridges
Status: CLOSED DUPLICATE of bug 876473
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-06 15:50 EST by Alexander Todorov
Modified: 2015-05-14 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:47:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2013-03-06 15:50:24 EST
Description of problem:

I notice that my app is taking too much space, lots of it are log files:

cron-1.4 - uses log rotate as it seems

metrics-0.1 and python-2.6 - don't. They use timestamps for the log file names.
I have nearly 50MB in log files which I have to clean up manually.

Please fix this or add some sort of setting for log rotate.
Comment 1 Luke Meyer 2013-03-12 16:47:33 EDT
It is a good idea and we have a user story to do it (US3111) - sadly not yet publicly visible but look for it at https://trello.com/board/openshift-origin-runtime/50fc6bb487602f214b003f71 when that team moves to Trello. It's not scheduled yet, sorry, you are of course welcome to work to implement it yourself.

See also https://openshift.redhat.com/community/forums/openshift/log-rotation-not-enabled

And you can use rhc tidy to clean up log files.

*** This bug has been marked as a duplicate of bug 876473 ***

Note You need to log in before you can comment on or make changes to this bug.