Bug 91880 - (IDE HPT366)System hangs with HPT366 and IBM Deskstar with kernel-2.4.20-13.7
(IDE HPT366)System hangs with HPT366 and IBM Deskstar with kernel-2.4.20-13.7
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-29 04:41 EDT by Marek Greško
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-21 07:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Greško 2003-05-29 04:41:33 EDT
Description of problem:
System hangs with UDMA failure with HPT366 and IBM Deskstar

Version-Release number of selected component (if applicable):
2.4.20-13.7

How reproducible:
After every boot.

Steps to Reproduce:
1. Install kernel-2.4.20-13.7
2. Boot the new kernel
3. System hangs with UDMA failure during boot.
    
Actual results:
System hangs.

Expected results:
System boots.

Additional info:
Comment 1 Alan Cox 2003-06-08 08:34:55 EDT
Which kernel were you using before that works ?
Also does booting with ide=nodma work (this will make it slow but mean we can
then do some
other tests)
Comment 2 Marek Greško 2003-06-09 07:25:27 EDT
We were using kernel 2.4.18-27.7.x and it worked perfectly. 
 
I cannot test ide=nodma now, because it is our produsction machine situated at 
our hosting provider. I will provide this information later. 
Comment 3 Alan Cox 2003-06-09 07:56:52 EDT
Ok if 18.27 fixed it then I know what problem it was and I'll close the bug. 

Comment 4 Marek Greško 2003-06-16 12:05:51 EDT
If nobody else encounters this bug. It is probably not a bug. Only hardware
problem. The disk is out of order forever. The new disk is not IBM Deskstar so I
cannot test it any more.

Sorry for your time.
Comment 5 Alan Cox 2003-06-21 07:31:35 EDT
Thanks for filing the bug. If someone else finds this bug and has the same
problem - please reopen it


Note You need to log in before you can comment on or make changes to this bug.