Bug 918938 - Crash in Impress when right-clicking selected word
Summary: Crash in Impress when right-clicking selected word
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-07 09:25 UTC by Mikkel Lauritsen
Modified: 2013-04-01 03:35 UTC (History)
6 users (show)

Fixed In Version: hunspell-1.3.2-10.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-01 03:35:44 UTC


Attachments (Terms of Use)
ODP file that reproduces crash (14.67 KB, application/vnd.oasis.opendocument.presentation)
2013-03-07 09:25 UTC, Mikkel Lauritsen
no flags Details
(part of) valgrind log (3.98 KB, text/plain)
2013-03-07 12:11 UTC, David Tardon
no flags Details

Description Mikkel Lauritsen 2013-03-07 09:25:59 UTC
Created attachment 706444 [details]
ODP file that reproduces crash

LibreOffice Impress crashes when right-clicking highlighted text.

This is fully reproduceable as follows:

1. Open the attached bug18.odp file in Impress
2. Highlight the word "erfaringer" for example by clicking it and pressing Ctrl+A
3. Right-click the word

Apparently the exact word "erfaringer" (which BTW is a properly spelled Danish word) is important, as removing any single character from the word seems to eliminate the crash. A new document containing the same word doesn't cause the crash either.

All installed LibreOffice components are version 3.6.5.2-5.fc18.x86_64; langpack-en and langpack-da are installed.

Comment 1 Mikkel Lauritsen 2013-03-07 09:38:34 UTC
The problem initially showed as Impress entering a livelock when right-clicking a larger selected block of text, but as I narrowed it down to the attached sample it has changed to crashing instead.

Comment 2 David Tardon 2013-03-07 12:11:21 UTC
Created attachment 706550 [details]
(part of) valgrind log

Comment 3 Caolan McNamara 2013-03-13 16:52:04 UTC
reproducible

Comment 4 Fedora Update System 2013-03-13 17:38:18 UTC
hunspell-1.3.2-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hunspell-1.3.2-10.fc18

Comment 5 Fedora Update System 2013-03-14 02:59:12 UTC
Package hunspell-1.3.2-10.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hunspell-1.3.2-10.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3829/hunspell-1.3.2-10.fc18
then log in and leave karma (feedback).

Comment 6 Mikkel Lauritsen 2013-03-15 08:10:35 UTC
Feedback left; works for me. Thanks!

Comment 7 Fedora Update System 2013-04-01 03:35:46 UTC
hunspell-1.3.2-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.