Bug 919092 - Pull in trust data from new Fedora source paths
Pull in trust data from new Fedora source paths
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: p11-kit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 466626
  Show dependency treegraph
 
Reported: 2013-03-07 10:21 EST by Stef Walter
Modified: 2013-03-19 14:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 14:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2013-03-07 10:21:05 EST
Update the p11-kit package to pull in trust data from new Fedora source paths. At this point these are:

%{_datadir}/pki/ca-trust-source
%{_sysconfdir}/pki/ca-trust/source

See: https://fedoraproject.org/wiki/Features/SharedSystemCertificates:SubTasks

In addition because ca-certificates is not yet placing data at these locations, we will temporarily pull in data from the old path:

%{_sysconfdir}/pki/tls/certs/ca-bundle.crt

We also want to split out the trust module from the main p11-kit package. This allows easier testing between the old and new systems, and allows the trust module to conflict with the libnssckbi.so file from older nss packages.
Comment 1 Stef Walter 2013-03-12 05:38:22 EDT
Done in p11-kit-0.6.3-1 package, which was uploaded to rawhide several days ago.

Note You need to log in before you can comment on or make changes to this bug.