Bug 9191 - NFS install doesn't work
NFS install doesn't work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-07 18:00 EST by Tim Waugh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 10:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of tcpdump -ieth0 -x -s 500 (6.12 KB, text/plain)
2000-02-08 14:49 EST, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2000-02-07 18:00:03 EST
I can't get beta3 to install over NFS.  Beta2 works fine with exactly the
same input:

- no special options at syslinux prompt
- English language for installation
- UK keyboard layout
- NFS image installation medium
- NE2000 driver io=0x300
- IP address 192.168.1.5, netmask 255.255.255.0, default gateway
  192.168.1.1, primary nameserver 192.168.1.1
- NFS server name "cyberelk", Red Hat directory
  "/usr/local/src/big/cdrom"

With beta2, it just works.  With beta3, the directory gets mounted
(cyberelk authenticates the mount request), but then a dialog box says:

        I could not mount that directory from the server

VT3 says:

...
mounting nfs path cyberelk:/usr/local/src/big/cdrom

VT4 says:

...
<4>eth0: NE2000 found at 0x300, using IRQ 5.
Comment 1 Jay Turner 2000-02-08 12:46:59 EST
Try specifying the FQDN for the NFS server.  Sounds like something is not
connecting with this install.  We are having no problems performing NFS
installations from porkchop, so I am pretty amazed that you are.
Comment 2 Tim Waugh 2000-02-08 14:49:59 EST
Created attachment 101 [details]
Output of tcpdump -ieth0 -x -s 500
Comment 3 Tim Waugh 2000-02-08 14:52:59 EST
Well, I am.  I tried using the FQDN but it made no difference.  I tried using a
US keymap too, just in case. ;-)

With 6.1.91 against the same NFS server (Red Hat Linux 6.0) and directory, it
gets further, i.e. to the point where it sees a different tree to the one it's
expecting.

I caught the network traffic -- see above.
Comment 4 Tim Waugh 2000-02-09 07:11:59 EST
I couldn't reproduce this on the machine here in the office that has an ISA
NE2000. :-(

On my home machine, this happens _every_ time, and I don't even know a
workaround.
Comment 5 Jay Turner 2000-02-09 10:29:59 EST
The way that I am reading this, you are performing an NFS installation from your
house and it is failing.  If this is the case, please have a conversation with
Bryan Andregg about global access to internal redhat machines.  He will probably
be able to shed light on your problem.
Comment 6 Tim Waugh 2000-02-09 10:57:59 EST
No, I'm using two machines at home, one of which is the server, and one the test
install box.  But I can't reproduce this on any other machine, so I guess I'll
leave this closed.

Note You need to log in before you can comment on or make changes to this bug.