Bug 91915 - CUPS not working with remote LPD queues
CUPS not working with remote LPD queues
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-29 14:44 EDT by Florin Andrei
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 06:20:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2003-05-29 14:44:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I configured the printers using the default GUI. I entered the correct hostname
for the print server, the correct queue names (remote Unix LPD queues), the
correct printer drivers (generic Postscript).
However, i can't print. I keep getting the error:

Remote host did not accept control file (115)

But if i use the Printer System Switcher and use LPD, and all configuration
pieces are the same, it works! I can print with no problem whatsoever.

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3

How reproducible:
Always

Steps to Reproduce:
1.configure cups to use remote Unix lpd queues
2.try to run a printing test
3.
    

Actual Results:  error message:
Remote host did not accept control file (115)

Expected Results:  I should be able to print to remote server.

Additional info:
Comment 1 Tim Waugh 2003-05-29 17:36:49 EDT
I strongly suspect this to be due to strict RFC-1179 checking.  There is a
check-box in the GUI, but unfortunately for CUPS it does nothing in Red Hat
Linux 9.  For LPRng it should work though.

In current rawhide (redhat-config-printer and cups) the checkbox should have the
desired effect.
Comment 2 Florin Andrei 2003-05-29 19:44:05 EDT
With CUPS, i used whatever's the default with that setting. Which, i think, is
unselected.
With LPD it works with it unselected, i didn't try to select it and see what
happens.
I'm too lazy to reconfigure again to CUPS. :-)

Even if the checkbox doesn't work in the GUI, is there any way to override it
manually in CUPS? I don't mind editing config files.
Comment 3 Tim Waugh 2003-05-30 05:42:27 EDT
Maybe LPRng does that by default now, not sure.

What is the remote LPD server?  An actual printer, or another computer?

There isn't really a config file you can edit to do this with CUPS; you just
need a newer version of both it and redhat-config-printer.
Comment 4 Florin Andrei 2003-05-30 14:33:27 EDT
The remote LPD server is a Unix server, having several printing queues. "Behind"
each queue there's a network printer, but that's transparent to the user (until
you actually have to walk down the hall to get your printed document from the
tray :-D).
nmap says:
Remote operating system guess: IRIX 6.5-6.5.15m

LPD always worked flawlessly with this printserver. It's the default printserver
for my department, used by hundreds of workstations (all sorts of Unices). I
could use it as a printserver from all Red Hat versions starting with...
whatever was the latest version around Christmas 2000.
With Red Hat 9, using the default config GUI, it works with the old printing
subsystem, it does not work with CUPS.
Comment 5 Tim Waugh 2003-06-27 06:20:42 EDT
So sounds like it's the RFC1179 option you need, and that works in rawhide.

Note You need to log in before you can comment on or make changes to this bug.