Bug 91928 - Files treated as case insensitive
Files treated as case insensitive
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-29 17:48 EDT by Seth Foley
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-29 17:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Foley 2003-05-29 17:48:45 EDT
Description of problem:
Most shell commands in RH9 accept all arguments without due regard for case. 
This is inconsistent with the default shell, bash, where autocompletion via the
[Tab] key is case sensitive, and with many other GNU/Linux systems where case
sensitivity is the norm.  There are several problems with this:

1. A user must execute two mv commands to change the case of a filename via the
shell.
2. Compatibility with existing GNU/Linux distributions (Mandrake and Debian, for
example) is diminished.

The problem can always be reproduced by executing the following statements in a
Terminal window:

1.  touch file.txt
2.  mv file.txt File.txt

Actual Results:  The shell replies that the files are the same.
Expected Results:  file.txt should have been renamed to File.txt.

I'm aware that there is some controversy about case sensitivity, but it seems
odd to provide a shell that does not wholly accept insensitivity while providing
commands that do.
Comment 1 Tim Waugh 2003-05-29 17:53:22 EDT
I have never (ever) seen this behaviour in bash, or in mv, or indeed in any of
the standard utilities shipped in Red Hat Linux.  Cannot reproduce it on Red Hat
Linux 9.
Comment 2 Tim Waugh 2003-05-29 17:55:46 EDT
Oh, I bet you're using a VFAT filesystem: the *filesystem* is case-insensitive,
by design.  Use ext3.

Note You need to log in before you can comment on or make changes to this bug.