Bug 91931 - traceback on lvmsize for large disks
Summary: traceback on lvmsize for large disks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-29 23:06 UTC by Elliot Peele
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 20:22:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elliot Peele 2003-05-29 23:06:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030517

Description of problem:
Anaconda tracebacks when it tries to get the partitions from disk and tries to
calculate the lvsize because an int is to small for large volumes.

I don't have a floppy handy so heres the traceback:

File "/usr/lib/anaconda/gui.py", line 761, in nextClicked
    self.displach.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/partitioning.py", line 57, in partitionObjectInitialize
    partitions.setFromDispl(diskset)
File "/usr/lib/anaconda/partitions.py", line 265, in setFromDisk
    lvsize = int(lvsize) / 2048.0
ValueError: int() literal too large: 2342780928



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install machine with large lvm volumes (in this case 1.1TB)
2. try to reinstall
3.
    

Actual Results:  anaconda tracebacks

Expected Results:  shouldn't traceback

Additional info:

I only tried this will large volumes (over 1TB).

Comment 1 Michael Fulbright 2003-06-30 19:36:32 UTC
Fixed in development tree.


Note You need to log in before you can comment on or make changes to this bug.