Bug 91937 - Flyspell broken in emacs 21.3-5
Flyspell broken in emacs 21.3-5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-29 21:29 EDT by Darren Brierton
Modified: 2015-01-07 19:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 02:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My ~/.emacs.el file (16.38 KB, text/plain)
2003-06-03 18:48 EDT, Darren Brierton
no flags Details
My ~/.emacs.customize.el file (9.72 KB, text/plain)
2003-06-03 18:49 EDT, Darren Brierton
no flags Details
My /usr/share/emacs/site-lisp/default.el (496 bytes, text/plain)
2003-06-03 18:50 EDT, Darren Brierton
no flags Details

  None (edit)
Description Darren Brierton 2003-05-29 21:29:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4b) Gecko/20030509

Description of problem:
I'm running a complete install of a fully up2date Red Hat Linux 9, but have been
very selectively trying some packages from Rawhide - notably emacs, mozilla and
epiphany.

Emacs 21.3-1 (from Rawhide previously) works absolutely fine. However, upgrading
to 21.3-5 breaks flyspell. It complains that there is no such program "ispell".

I can provide further detail of my .emacs, etc. if needed.

Version-Release number of selected component (if applicable):
emacs-21.3-5

How reproducible:
Always

Steps to Reproduce:
1. Install emacs-21.3-5, emacs-el-21.3-5, and emacs-leim-21.3-5.
2. Start emacs.
3. Load any file whose mode would start flyspell.
    

Actual Results:  Emacs won't load the file and complains that it can't find ispell.

Expected Results:  Emacs would load the file and turn on flyspell.
Comment 1 Jens Petersen 2003-06-02 17:36:52 EDT
I'm not familiar with flyspell, can you give an explicit example
of how to reproduce the problem?

Can you reproduce the problem in a vanilla emacs started with say "emacs -q"?

Currently `ispell-program-name' should be being set to aspell in
"/usr/share/emacs/site-lisp/default.el".
Perhaps you have `inhibit-default-init' non-nil?
Comment 2 Darren Brierton 2003-06-03 14:34:43 EDT
Start emacs (21.3-5) using emacs -q. Emacs loads with banner. Click on banner to
clear it, and drop into *scratch* buffer. Right click on mode line on (Lisp
Interaction) and select Flyspell from pop up menu. Result: emacs beeps and prints:

Searching for program: no such file or directory, ispell

This does NOT happen with the previous build of emacs 21.3 from Rawhide.
Comment 3 Jens Petersen 2003-06-03 18:28:51 EDT
Can you attach your .emacs and "/usr/share/emacs/site-lisp/default.el"
files, please?

A quick fix is just to add

   (setq ispell-program-name "aspell")

to your .emacs file.
Comment 4 Darren Brierton 2003-06-03 18:47:57 EDT
Okay, I'll attach ~/.emacs.el, ~/.emacs.customize.el (the file that customize
writes to) and my /usr/share/emacs/site-lisp/default.el next, but shouldn't
emacs -q cause emacs to ignore those files?
Comment 5 Darren Brierton 2003-06-03 18:48:51 EDT
Created attachment 92126 [details]
My ~/.emacs.el file
Comment 6 Darren Brierton 2003-06-03 18:49:30 EDT
Created attachment 92127 [details]
My ~/.emacs.customize.el file
Comment 7 Darren Brierton 2003-06-03 18:50:38 EDT
Created attachment 92128 [details]
My /usr/share/emacs/site-lisp/default.el
Comment 8 Jens Petersen 2003-06-03 22:30:00 EDT
And which version of aspell do you have?  No
"/usr/share/emacs/site-lisp/site-start.d/aspell-init.el" I take it?

Anyway, in the next built I will bring back the above ispell-program-name
setting in site-start.el, since I agreed with the aspell pkg owner that
site-start.el should carry the setting.  Thanks for the report.
Comment 9 Darren Brierton 2003-06-03 23:02:17 EDT
Aha! It's all Ximian's fault!

I installed their Evolution 1.3.92, which required the removal of the original
RHL9 aspell package and the installation of theirs:

$ rpm -q aspell
aspell-0.50.3-1.ximian.2

$ ls /usr/share/emacs/site-lisp/site-start.d/aspell-init.el
ls: /usr/share/emacs/site-lisp/site-start.d/aspell-init.el: No such file or
directory

(Although the ispell-program-name setting in site-start.el which was removed for
 21.3-5 but was presumably in the previous 21.3 Rawhide package explains why it
was only with this package of 21.3 that I had this problem.)
Comment 10 Darren Brierton 2003-06-10 10:13:59 EDT
I just tried the new emacs packages on Raw Hide (21.3-6, dated 5th June) and the
problem is not solved - naturally I can work around the problem by adding:

(setq ispell-program-name "aspell")

to my ~/.emacs, but if I comment that line out and start emacs then I get the
same old error (Searching for program: no such file or directory, ispell).

I wasn't sure if this release was meant to fix this or not, so I thought I'd
better just let you know.
Comment 11 Jens Petersen 2003-10-27 08:14:49 EST
I think the latest aspell package contains the ispell compatibility
wrapper again.  So I believe is now working ok out of the box.

Note You need to log in before you can comment on or make changes to this bug.