Bug 91954 - Stub support for Exim broken
Stub support for Exim broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-switch-mail (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-30 06:05 EDT by Jon Warbrick
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-17 10:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Warbrick 2003-05-30 06:05:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Description of problem:
redhat-switch-mail contains undocumented stub support for the Exim MTA, in
addition to postfix and sebdmail. But it's broken. get_default_mta in
functions.py checks for the current MTP being /usr/sbin/exim.postfix when it
should be /usr/sbin/sendmail.exim

Additionally it would help if the switch function could correctly stop or start
all three posible MTA services, not just sendmail and postfix.

I apreciate that you don't distribute an Exim RPM (though I think you should!),
however with this fix redhat-switch-mail would at least support the RPM I'm
building.

Version-Release number of selected component (if applicable):
redhat-switch-mail-0.5.17-1

How reproducible:
Always

Steps to Reproduce:
1. Take a look at the functions.py source
2.
3.
    

Actual Results:  redhat-switch-mail doesn't recognise Exim as the currently
installed MTA

Expected Results:  redhat-switch-mail could usefully recognise Exim as the
currently installed MTA

Additional info:
Comment 1 Ngo Than 2003-06-02 06:47:21 EDT
exim is not yet supported in current redhat-switch-mail, because we don't have
it in the distribution.

I will add it in next version.

Comment 2 Ngo Than 2003-07-17 10:34:12 EDT
it's fixed now in 0.5.19, which will be available in next days. Thanks for your
report.

Note You need to log in before you can comment on or make changes to this bug.