Bug 91956 - Modem configuration including password are during boot and when I run neat
Modem configuration including password are during boot and when I run neat
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-30 06:08 EDT by Oeystein Olsen
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 08:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oeystein Olsen 2003-05-30 06:08:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
When I run the command neat from a terminal window, the complete configuration
of the modem is printed. This configuration also includes my password in
plain-text. This information is also printed during the boot process. 




Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. Setup different network profiles
2. Install driver for a softmodem.
3. Configure the modem using neat (in the Common profile)
4. Run neat or reboot machine.
    

Actual Results:  Password and other information printed in cleartext. 

Expected Results:  Nothing.

Additional info:
Comment 1 Harald Hoyer 2003-05-30 08:27:45 EDT
thx... some security fixes are already in cdrtools
Comment 2 Harald Hoyer 2003-05-30 08:29:46 EDT
oops ... wrong bugzilla # :)

for your problem:
http://people.redhat.com/harald/redhat-config-network
Comment 3 Mark J. Cox (Product Security) 2003-12-19 08:23:58 EST
Please see RHBA-2003:183  	

Note You need to log in before you can comment on or make changes to this bug.