Bug 9197 - timetool does not work well under UTC
Summary: timetool does not work well under UTC
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: timetool   
(Show other bugs)
Version: 5.2
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-07 23:49 UTC by ttaka
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-07 23:54:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ttaka 2000-02-07 23:49:18 UTC
timetool uses the config file /etc/sysconfig/clock generated
by timeconfig and assumes that if the hw clock is UTC,
/etc/sysconfig/clock contains the regular expression ".*GMT.*".
But unfortunately, what is expected is the string "UTC="yes""
when the hw clock is UTC.

Because of this wrong regexp, timetool does not work well when
the hw clock is UTC.

Comment 1 Bill Nottingham 2000-02-07 23:54:59 UTC
This is fixed in the currently shipping timetool.


Note You need to log in before you can comment on or make changes to this bug.