Bug 919705 - /usr/libexec/xendomains is not executable
/usr/libexec/xendomains is not executable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-09 12:28 EST by Ahmon Dancy
Modified: 2013-04-20 16:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-13 20:25:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ahmon Dancy 2013-03-09 12:28:37 EST
Description of problem:

xendomains.service doesn't work because /usr/libexec/xendomains is not executable.

On startup, I see this message:

Jan 17 09:03:00 xen systemd[834]: Failed at step EXEC spawning /usr/libexec/xendomains: Permission denied


Version-Release number of selected component (if applicable):

xen-4.1.4-6.fc17.x86_64
Comment 1 Ahmon Dancy 2013-03-09 12:44:23 EST
Further, if I manually chmod +x /usr/libexec/xendomains, it doesn't actually work (at least for 'stop' mode).  It ultimately tries to run 'xl list -l' which results in "Neither kernel nor bootloader specified".  "xm list -l" would have worked but since the script finds 'xl' first, it tries to use it in favor of 'xm'.
Comment 2 Fedora Update System 2013-04-04 19:11:13 EDT
xen-4.2.1-10.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xen-4.2.1-10.fc18
Comment 3 Fedora Update System 2013-04-04 20:03:12 EDT
xen-4.1.4-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xen-4.1.4-7.fc17
Comment 4 Michael Young 2013-04-04 20:05:56 EDT
xen-4.1.4-7.fc17 makes /usr/libexec/xendomains executable. I am still looking at the second part of the problem, but it may be an selinux issue.
Comment 5 Fedora Update System 2013-04-05 18:55:18 EDT
Package xen-4.1.4-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xen-4.1.4-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4927/xen-4.1.4-7.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-04-09 13:58:21 EDT
xen-4.2.1-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xen-4.2.1-10.fc19
Comment 7 Fedora Update System 2013-04-13 20:25:29 EDT
xen-4.2.1-10.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-04-13 20:30:16 EDT
xen-4.1.4-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-04-20 16:15:34 EDT
xen-4.2.1-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.