Bug 919785 (CVE-2013-2275) - CVE-2013-2275 Puppet: default auth.conf allows authenticated node to submit a report for any other node
Summary: CVE-2013-2275 Puppet: default auth.conf allows authenticated node to submit a...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2013-2275
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 919788 919790 919791 920843 920845 924458 995661
Blocks: 919786 919787 921763
TreeView+ depends on / blocked
 
Reported: 2013-03-10 05:11 UTC by Kurt Seifried
Modified: 2021-02-17 07:56 UTC (History)
20 users (show)

Fixed In Version: puppet 2.6.18, puppet 2.7.21, puppet 3.1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-11 07:01:18 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2013:0710 0 normal SHIPPED_LIVE Important: puppet security update 2013-04-05 00:18:54 UTC

Description Kurt Seifried 2013-03-10 05:11:04 UTC
Moses Mendoza (moses@puppetlabs.com) reports:

CVE-2013-2275 - Incorrect default report ACL
* Affected versions: 0.25.0 and greater
* Resolved in Puppet 2.6.18, 2.7.21, 3.1.1, Puppet Enterprise 1.2.7, 2.7.2

The default auth.conf allows an authenticated node to submit a report
for any other node, which is a problem for compliance. It should be
more restrictive by default so that a node is only allowed to save its
own report.

Comment 2 Vincent Danen 2013-03-12 21:37:48 UTC
Created puppet tracking bugs for this issue

Affects: epel-all [bug 920843]

Comment 3 Vincent Danen 2013-03-12 21:41:51 UTC
Created puppet tracking bugs for this issue

Affects: fedora-all [bug 920845]

Comment 4 Kurt Seifried 2013-03-15 04:59:18 UTC
For the puppet roll-up patches please see Bz 919783 for the patch files.

Comment 6 Murray McAllister 2013-03-27 01:39:23 UTC
External References:

https://puppetlabs.com/security/cve/cve-2013-2275/

Comment 7 Murray McAllister 2013-03-27 07:26:44 UTC
Acknowledgements:

Red Hat would like to thank Puppet Labs for reporting this issue.

Comment 8 errata-xmlrpc 2013-04-04 20:20:39 UTC
This issue has been addressed in following products:

  OpenStack Folsom for RHEL 6

Via RHSA-2013:0710 https://rhn.redhat.com/errata/RHSA-2013-0710.html

Comment 9 Fedora Update System 2013-04-05 22:36:55 UTC
puppet-2.6.18-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-04-05 22:38:04 UTC
puppet-2.6.18-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Kurt Seifried 2013-07-26 06:18:44 UTC
The Red Hat Security Response Team has rated this issue as having moderate security impact in CloudForms 1.1. This issue is not currently planned to be addressed in future updates.

Comment 12 Fedora Update System 2013-08-02 03:24:49 UTC
puppet-3.1.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.