Bug 919835 - Multiple Login Dialog Boxes on Multi-Monitor Setups
Summary: Multiple Login Dialog Boxes on Multi-Monitor Setups
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-workspace
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 924914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-10 11:49 UTC by Eli Wapniarski
Modified: 2015-11-02 01:36 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-25 12:41:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 316295 None None None Never

Description Eli Wapniarski 2013-03-10 11:49:17 UTC
kscreensaver 4.10.1

This has been filed upstream at:
https://bugs.kde.org/show_bug.cgi?id=316295

A login dialog box appears per screen when trying to unlock a locked session as opposed to only 1 dialog box.

Comment 1 Martin Bříza 2013-03-11 12:30:28 UTC
Well, is this really a bug? I would personally call it an enhancement...

Comment 2 Kevin Kofler 2013-03-23 00:47:12 UTC
*** Bug 924914 has been marked as a duplicate of this bug. ***

Comment 3 John Florian 2013-03-25 12:19:52 UTC
(In reply to comment #1)
> Well, is this really a bug? I would personally call it an enhancement...

How can this be an enhancement?  I now have to visually scan each of my 4 large screens to find out which one (if any) has focus.

Also, seeing 4 duplicate screen savers is not nearly as neat looking as one that spans such a large area, especially with the OpenGL variants.

Comment 4 Martin Bříza 2013-03-25 12:36:56 UTC
My personal opinion is having password dialog for every screen is fine and the fact there are focus issues is a different story... reported here for example: https://bugs.kde.org/show_bug.cgi?id=316084

Comment 5 Rex Dieter 2013-03-25 12:41:23 UTC
As this general issue was an upstream design decision, there's not really much we (as downstream) can do realistically to address this.  That said, I'll mark this closed->upstream , feel free to send further comments, dialog in the upstream report in https://bugs.kde.org/show_bug.cgi?id=316295


Note You need to log in before you can comment on or make changes to this bug.