Bug 919908 - yum install reports KeyError: 'sphinx'
Summary: yum install reports KeyError: 'sphinx'
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sphinx-webtools
Version: 18
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-10 21:04 UTC by H.-P. Sorge
Modified: 2013-06-13 22:30 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-06-07 03:06:06 UTC


Attachments (Terms of Use)

Description H.-P. Sorge 2013-03-10 21:04:10 UTC
Description of problem:
CAP --------------------->
(197/508): asterisk-sounds-core-en_AU-siren7-1.4.22-3.fc18.noarch.rpm                                            | 3.2 MB  00:00:05     
Error processing line 2 of /usr/lib/python2.7/site-packages/sphinx.webtools-0.2.1-py2.7-nspkg.pth:

  Traceback (most recent call last):
    File "/usr/lib64/python2.7/site.py", line 164, in addpackage
      exec line
    File "<string>", line 1, in <module>
  KeyError: 'sphinx'

Remainder of file ignored
--------------------------------< CAP

Version-Release number of selected component (if applicable):
current yum


How reproducible:
use yum to install packages


Steps to Reproduce:
1. use yum to install packages ( not all packages present above error )
2.
3.
  
Actual results:
Hopefully not an incomplete install

Expected results:
No error message


Additional info:

I did reinstalled sphinx-webtool - no change

Comment 1 guo jiang 2013-05-19 09:07:06 UTC
I encountered the same problem.
Fedora 18

Comment 2 Zdeněk Pavlas 2013-05-20 09:19:56 UTC
Not a Yum bug.  Your python install is broken, probably due to a bug in sphinx.webtools.

1) could you start python interactively, or does it err with the same message?

2) check the /usr/lib/python2.7/site-packages/sphinx.webtools-0.2.1-py2.7-nspkg.pth content.  It should contain a short script to update python environment (module include paths etc) for sphinx.webtools.

3) does uninstalling sphinx.webtools with rpm fix this?

Comment 3 H.-P. Sorge 2013-05-26 16:01:17 UTC
Indeed, un-install of sphinx-webtools fixes the problem.

I changed Component from yum to sphinx-webtools.

Comment 4 Fedora Update System 2013-05-28 21:55:09 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6

Comment 5 Fedora Update System 2013-05-28 21:55:25 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc19

Comment 6 Fedora Update System 2013-05-28 21:55:43 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc18

Comment 7 Fedora Update System 2013-05-28 21:55:59 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc17

Comment 8 Fedora Update System 2013-05-29 17:32:10 UTC
Package sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-5999/sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6
then log in and leave karma (feedback).

Comment 9 H.-P. Sorge 2013-05-30 09:00:39 UTC
What am I missing? ....


[root@localhost ~]# yum update --enablerepo=epel-testing sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6
Loaded plugins: langpacks, presto, refresh-packagekit
Error getting repository data for epel-testing, repository not found


[root@localhost ~]# rpm -Uvh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
Retrieving http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
warning: /var/tmp/rpm-tmp.Se6V9M: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY
error: Failed dependencies:
        fedora-release conflicts with epel-release-6-8.noarch

Comment 10 Fedora Update System 2013-06-07 03:06:06 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-06-07 03:06:42 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-06-07 04:39:40 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 H.-P. Sorge 2013-06-09 10:12:55 UTC
I installed from stable on F18.
The problem is fixed.

Comment 14 Fedora Update System 2013-06-13 22:30:50 UTC
sphinx-webtools-0.2.1-20120528.hg86a2eac02afe.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.