Bug 92000 - updfstab not recognising external firewire drive
updfstab not recognising external firewire drive
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-30 17:08 EDT by Darren Brierton
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 18:36:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Brierton 2003-05-30 17:08:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4b) Gecko/20030509

Description of problem:
I have an Iomega 120GB FireWire external HDD. Kudzu recognises the device, and
configures it as /dev/sda. In the Hardware Browser the drive shows up under
"SCSI devices" as

        Iomega [00d0b8] / Iomega External Hard Drive [000001]
        
        Manufacturer:   Unknown
        Driver:         sbp2
        
Under "Hard Drives" in the Hardware Browser the single partition shows
up under /dev/sda as

        sda1    1       15017   117797  fat32

and I can mount the drive manually by

        mount /dev/sda1 /mnt/firewire120

However, although Kudzu does seem to call updfstab nothing is added to
fstab. I looked through /etc/updfstab.conf.default and none of the
entries in there look like they would match the drive. I know I can
manually edit /etc/fstab myself, but actually I like the idea of
kudzu/updfstab/magicdev automatically taking care of removable and
hot-pluggable media.


Version-Release number of selected component (if applicable):
kudzu-0.99.99-1

How reproducible:
Always

Steps to Reproduce:
Connect external FireWire drive to computer.
    

Actual Results:  kudzu configures drive as /dev/sda but doesn't mount it

Expected Results:  fstab automatically adjusted, drive mounted, and icon
(preferably with a sensible name like "Iomega External Hard Drive") appear on
nautilus desktop

Additional info:

Contents of /proc/bus/ieee1394/devices:

Node[00:1023]  GUID[00d0b87500007594]:
  Vendor ID: `Iomega  ' [0x00d0b8]
  Capabilities: 0x0083c0
  Bus Options:
    IRMC(0) CMC(0) ISC(0) BMC(0) PMC(0) GEN(0)
    LSPD(0) MAX_REC(64) CYC_CLK_ACC(255)
  Unit Directory 0:
    Vendor/Model ID: Iomega   [00d0b8] / Iomega External Hard Drive   [000001]
    Software Specifier ID: 00609e
    Software Version: 010483
    Driver: SBP2 Driver
    Length (in quads): 8
Node[01:1023]  GUID[324fc00001363810]:
  Vendor ID: `Linux OHCI-1394' [0x000000]
  Capabilities: 0x0083c0
  Bus Options:
    IRMC(1) CMC(1) ISC(1) BMC(0) PMC(0) GEN(0)
    LSPD(2) MAX_REC(2048) CYC_CLK_ACC(0)
  Host Node Status:
    Host Driver     : ohci1394
    Nodes connected : 2
    Nodes active    : 2
    SelfIDs received: 2
    Irm ID          : [01:1023]
    BusMgr ID       : [01:1023]
    In Bus Reset    : no
    Root            : yes
    Cycle Master    : yes
    IRM             : yes
    Bus Manager     : yes
Comment 1 Bastien Nocera 2004-02-25 06:55:40 EST
Does adding those lines to /etc/updfstab.conf.default work?

device harddrive {
    partition 1
    match   hd "Iomega External Hard Drive"
}
Comment 2 Darren Brierton 2004-02-25 09:28:25 EST
No, I'm afraid that adding those lines makes no difference. It may be
because I can't mount the device at all unless I first run the
rescan-scsi-bus.sh script as explained here:

http://www.linux1394.org/sbp2.html#hotplug

Could that be it? Does kudzu first test to see if the drive is
mountable before adding an entry to /etc/fstab?
Comment 3 Bastien Nocera 2004-02-25 11:02:38 EST
This entry should work fine with a 2.6 kernel, as it wouldn't need
rescan-scsi-bus.sh.
I don't think that modifying kudzu is really an option at this stage.
Comment 4 Darren Brierton 2004-02-25 11:21:12 EST
When I finally move over to a 2.6.x kernel I'll add a comment. Cheers
Bastien!
Comment 5 Bill Nottingham 2005-02-07 18:36:19 EST
This has moved to HAL in later releases; this isn't going to get
changed in updfstab.

Note You need to log in before you can comment on or make changes to this bug.