Bug 92003 - Really weird way of adding new printers
Really weird way of adding new printers
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2003-05-30 18:19 EDT by Michal Jaegermann
Modified: 2007-04-18 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-05 13:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2003-05-30 18:19:15 EDT
Description of problem:

I eventually found it but guessing that in order to add another
queue/printer in RH9 one has to use "Properties" of an existing one
was a somewhat strange experience.  The first queue is not a problem
but additions are.  Please make this somewhat more obvious.  Clicking
at random in all possible places is not a good answer to that.
Comment 1 Tim Waugh 2003-05-30 18:57:39 EDT
Why was 'System Settings->Printing' not an obvious thing to try?  There's a
great big 'New' button (first one).

Perhaps the menu item need renaming?
Comment 2 Michal Jaegermann 2003-05-30 19:40:36 EDT
No, we are talking about this prominent default printer picture on a panel,
which seems like an obvious thing to try, which in a "tool tips" comment
talks something about a printer configuration.  Especially that this worked
for the first time. :-)

I guess that if the first attempt would send you to 'System Settings->Printing'
menus, I mean in a explicit manner, then expectation that on the second try
one would go there would be reasonable.  Right now I am willing to bet that
vast majority of users will do the same thing which I did only they may to
fail to find where this "New" button hides.  Once you will get there things
are fine.  I run some informal and un-scientific tests for that with some
"naive" users.  Results tell me that my chances of winning such bet would
be very high.
Comment 3 Tim Waugh 2003-05-31 04:49:42 EDT
Ah, that was added to fix bug #81047 (offer to add a printer if there are none).
 Okay, that dialog could point you to System Settings->Printing then.

Or perhaps there should be some 'Add Printer' icon in the window.  Not sure; I'm
not a GUI person.
Comment 4 Havoc Pennington 2003-05-31 04:58:49 EDT
Remind me which app the icon launches if you already have a printer?
Comment 5 Tim Waugh 2003-05-31 05:45:46 EDT
It launches gnome-print-manager in any case; that in turn asks you if you want
to launch redhat-config-printer if there are no printers configured.
Comment 6 Michal Jaegermann 2003-05-31 12:28:32 EDT
> launch redhat-config-printer if there are no printers configured.

That "no printers configured" is a key here.  It worked before to
define a printer and it does not work now.  An extra button to
launch redhat-config-printer would solve the issue.  How it should be
marked is a good question.  "Manage Printers"?  You may want to delete
one as well.

You can get there by invoking "Properties" of an already defined printer
but this is likely not the way it was intended.

Hm, maybe this is filed against a wrong component; but I am not sure
how responsibilities are split here.
Comment 7 Bill Nottingham 2006-08-04 23:54:41 EDT
Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks.

Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
They are maintained by the Fedora Legacy project (http://www.fedoralegacy.org/)
for security updates only. If this is a security issue, please reassign to the
'Fedora Legacy' product in bugzilla. Please note that Legacy security update
support for these products will stop on December 31st, 2006.

If this is not a security issue, please check if this issue is still present
in a current Fedora Core release. If so, please change the product and version
to match, and check the box indicating that the requested information has been

If you are currently still running Red Hat Linux 7.3 or 9, please note that
Fedora Legacy security update support for these products will stop on December
31st, 2006. You are strongly advised to upgrade to a current Fedora Core release
or Red Hat Enterprise Linux or comparable. Some information on which option may
be right for you is available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Any bug still open against Red Hat Linux 7.3 or 9 at the end of 2006 will be
closed 'CANTFIX'. Again, if this bug still exists in a current release, or is a
security issue, please change the product as necessary. We thank you for your
help, and apologize again that we haven't handled these issues to this point.
Comment 8 Michal Jaegermann 2006-08-05 13:18:09 EDT
Not applicable any longer.  Many things changed in the meantime.

Note You need to log in before you can comment on or make changes to this bug.