Bug 92011 - Mozilla 1.4 doesn't get "placed" correctly by metacity
Mozilla 1.4 doesn't get "placed" correctly by metacity
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2003-05-31 00:05 EDT by Darren Brierton
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-12-02 16:09:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Complete output of xprop -name Mozilla (11.94 KB, text/plain)
2003-06-03 14:08 EDT, Darren Brierton
no flags Details

  None (edit)
Description Darren Brierton 2003-05-31 00:05:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4b) Gecko/20030509

Description of problem:
I'm not entirely sure if this is a bug, or even if it is what the correct
terminology to describe it is.

I'm running a complete install of Red Hat Linux 9 completely up2date, with just
a few packages from Rawhide: mozilla, epiphany, and emacs.

The version of Mozilla shipped with RH9 (1.2.1?) used to be correctly "placed"
on the desktop when running GNOME with metacity as the window manager: i.e. it
would be "tiled" next to other windows if there was available space, and if not
it would be "cascaded" from the top left corner of the screen (i.e. placed so
that its title bar was below the title bar of the last opened window and its
left border to the right of the left window border of the last opened window).

However, now, regardless of how small or large Mozilla's window is it always
opens in the top left corner of the screen (but not obscuring any panels). The
fact that it doesn't obscure any panels suggests that it is partly being
positioned correctly, but the fact that it always open in the top left corner
regardless of whether there is space to tile it or cascade it suggests that
something is going wrong.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install mozilla 1.4b from Rawhide
2. Start GNOME desktop with metacity as the window manager.
3. Open Mozilla.

Actual Results:  Mozilla window is positioned in the top left corner of the screen.

Expected Results:  Mozilla should be tiled next to other windows if there is
availale room, or otherwise cascaded.

Additional info:
Comment 1 Darren Brierton 2003-05-31 09:12:22 EDT
Confirming that the problem is also in latest Mozilla 1.4 (RC1) packages on
Rawhide. Changing summary from Mozilla 1.4b to 1.4 reflect this.
Comment 2 Christopher Blizzard 2003-06-02 11:06:47 EDT
Havoc?  Any ideas?  
Comment 3 Havoc Pennington 2003-06-02 12:49:08 EDT
Run xprop on the mozilla window, if your WM_NORMAL_HINTS have PPosition 
or USPosition set then mozilla is overriding window manager placement. 
This will happen if you call gtk_window_move().
Comment 4 Darren Brierton 2003-06-03 14:07:27 EDT
The output of xprop -name Mozilla on a new (blank) Mozilla windows which has
open in the top left corner of the screen gives the following output for

                program specified location: 0, 0
                program specified minimum size: 0 by 0
                window gravity: NorthWest

I'll create an attachment for the full output.
Comment 5 Darren Brierton 2003-06-03 14:08:36 EDT
Created attachment 92118 [details]
Complete output of xprop -name Mozilla
Comment 6 Havoc Pennington 2003-06-03 14:09:19 EDT
The problem is this:
  program specified location: 0, 0

Need to get rid of that, then it will work.
Comment 7 Christopher Blizzard 2003-06-04 11:01:20 EDT
There should be an entry in the localstore.rdf in your profile
(~/.mozilla/<profile>/seed/localstor.rdf) that looks something like this:

  <RDF:Description about="chrome://navigator/content/navigator.xul#main-window"
                   screenY="35" />

Do you have something along those lines?
Comment 8 Darren Brierton 2003-06-04 11:19:28 EDT
I have a file ~/.mozilla/default/localstore.rdf - it's quite large, do you want
me to attach it?
Comment 9 Darren Brierton 2003-06-04 11:50:33 EDT
Sorry, Chris, I misread your earlier comment (I though you were asking if I have
the file). I do indeed have an entry like that in
~/.mozilla/default/localstore.rdf. This is it:

<RDF:Description about="chrome://navigator/content/navigator.xul#main-window"
                   screenY="116" />
Comment 10 Darren Brierton 2003-06-15 08:54:46 EDT
Chris - I originally files this bug against Redhat Rawhide because Mozilla 1.2.1
in RHL9 was being positioned correctly by Metacity, and so my initial thought
was that this was a problem with the Rawhie packages. However, I've just
installed XD2, and Ximian's Mozilla 1.3 ALSO does NOT get correctly positioned
by Metacity. In which case, perhaps this is a general problem with Mozilla >=
1.3, and this bug should be moved to bugzilla.mozilla.org where it might have
greater visibility?
Comment 11 Darren Brierton 2003-11-20 11:57:28 EST
This has been reported on bugzilla.mozilla.org (twice):


I propose resolving as UPSTREAM.
Comment 12 Darren Brierton 2003-11-20 12:17:39 EST
Sigh. Didn't mean to actually close the bug - just propose that it be
closed resolved UPSTREAM. Will reopen and let an official Red Hat
person decide what's best.
Comment 13 Christopher Blizzard 2003-12-02 16:09:15 EST
Marking UPSTREAM.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.