Bug 920190 - rpmbuild processes %include directive even if inside non-matching %if
Summary: rpmbuild processes %include directive even if inside non-matching %if
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords: Upstream
: 920252 (view as bug list)
Depends On: 782970
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-11 14:22 UTC by Florian Festi
Modified: 2013-11-21 21:39 UTC (History)
5 users (show)

Fixed In Version: rpm-4.8.0-33.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 782970
Environment:
Last Closed: 2013-11-21 21:39:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1665 normal SHIPPED_LIVE rpm bug fix update 2013-11-20 21:53:00 UTC

Description Florian Festi 2013-03-11 14:22:37 UTC
+++ This bug was initially created as a clone of Bug #782970 +++

Created attachment 556142 [details]
Sample spec demonstrating the bug

Description of problem:

It appears, that the %include directives are processes at all times -- even if they are inside unmatching %ifos.

Version-Release number of selected component (if applicable):

rpmbuild --version
RPM version 4.4.2.3

How reproducible:
Always

Steps to Reproduce:
1. Attempt `rpmbuild -bb test.spec' using the attached sample spec-file on any OS.
  
Actual results:

error: Unable to open no-such-file.inc: No such file or directory
error: Package has no %description: foo

Expected results:
Some other error -- the `no-such-file.inc' should not be mentioned.

--- Additional comment from Panu Matilainen on 2012-02-28 05:21:54 EST ---

> rpmbuild --version
> RPM version 4.4.2.3

Generally speaking you should test with the version you're reporting a bug for, Fedora rawhide has rpm 4.9.x, not the rather ancient 4.4.x.  Doesn't matter in this case though, the bug is probably as old as support for %include itself...
Fixed upstream now, leaving this open for Fedora tracking.

--- Additional comment from Fedora Update System on 2012-03-07 06:34:32 EST ---

rpm-4.9.1.2-14.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rpm-4.9.1.2-14.fc17

--- Additional comment from Fedora Update System on 2012-03-07 06:37:04 EST ---

rpm-4.9.1.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpm-4.9.1.2-6.fc16

--- Additional comment from Mikhail T. on 2012-03-07 13:06:34 EST ---

Thanks, all. Any chance to see the fix in RedHat as well? We are using 5.6 Tikanga here...

--- Additional comment from Fedora Update System on 2012-03-07 23:59:11 EST ---

Package rpm-4.9.1.2-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-4.9.1.2-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3336/rpm-4.9.1.2-6.fc16
then log in and leave karma (feedback).

--- Additional comment from Panu Matilainen on 2012-03-08 02:37:14 EST ---

(In reply to comment #4)
> Thanks, all. Any chance to see the fix in RedHat as well? We are using 5.6
> Tikanga here...

You'll need to file separate bug(s) for the affected products (for practical purposes that'd be RHEL 5 and 6) if you want to try to get this fixed in existing RHEL versions as well.

--- Additional comment from Mikhail T. on 2012-03-08 08:56:14 EST ---

Changing the affected "Product" to RHEL5.

--- Additional comment from Panu Matilainen on 2012-03-08 08:59:56 EST ---

Don't do that. File a new bug(s) or clone this one but you can't reuse the same bug for something with an entirely different process of handling these things. Changing back to Fedora.

--- Additional comment from Mikhail T. on 2012-03-08 09:07:19 EST ---

Panu, I'm rather disappointed, that RedHat is making paying customers jump through such hoops to get a bug fixed in the production version of the flagship product.

Sheer appreciation for my diagnosing the bug, bothering to file it, and patiently waiting for resolution should've lead you to taking care of the necessary "process" yourself.

Nevertheless, I will try to follow your instructions, but do note, that you've just added one more reason for us to abandon RHEL in favor of Fedora.

--- Additional comment from Panu Matilainen on 2012-03-08 09:52:02 EST ---

As a paying customer, you should be using the official RHEL support channels to get priorized as one and to have the process taken care of for you. Bugzilla is merely a bug tracking mechanism (which gets reports from people running clones and whatnot) and nothing more, and engineers like me looking at bugzilla have no way of knowing who's a customer and who's not when it's not coming through the official channels.

Also please realize there's no automatic connection between bugs filed against any given Fedora version or component to corresponding RHEL component - bug fixes for RHEL are much more selectively applied than for Fedora to minimize risk of regressions, the versions between the two often are radically different, the maintainer can and often does differ between the two etc.

In any case, thanks for reporting the long-standing bug.

--- Additional comment from Mikhail T. on 2012-03-08 10:12:46 EST ---

> no way of knowing who's a customer and who's not

Why would a non-customer care about RHEL at all?..

--- Additional comment from Fedora Update System on 2012-03-11 19:22:04 EDT ---

rpm-4.9.1.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Fedora Update System on 2012-03-21 15:06:12 EDT ---

rpm-4.9.1.2-14.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 1 Panu Matilainen 2013-03-12 08:48:50 UTC
*** Bug 920252 has been marked as a duplicate of this bug. ***

Comment 2 RHEL Product and Program Management 2013-07-25 21:10:03 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 7 errata-xmlrpc 2013-11-21 21:39:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1665.html


Note You need to log in before you can comment on or make changes to this bug.