This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 9202 - reboot requires access to DISPLAY
reboot requires access to DISPLAY
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-07 21:25 EST by Kjetil T. Homme
Modified: 2014-03-16 22:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 13:17:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2000-02-07 21:25:24 EST
If DISPLAY is set to point at server which root lacks access to,
you can get two equally absurd results:

# /sbin/reboot
Xlib: connection to "haey.ifi.uio.no:0.0" refused by server
Xlib: Client is not authorized to connect to Server

Broadcast message from root (pts/0) Tue Feb  8 03:27:36 2000...

The system is going down for reboot NOW !!

(this "works")

# /sbin/reboot
X11 connection requests different authentication protocol:
'MIT-MAGIC-COOKIE-1' vs. ''.
Gdk-ERROR **: X connection to ifi.uio.no:11.1 broken (explicit kill or
server shutdown).
#
(this fails completely)

Lowlevel tools like reboot has no business talking X11.

(I couldn't reproduce this behaviour when I rebuilt sysvinit from the
SRPM.)
Comment 1 Bill Nottingham 2000-02-08 13:17:59 EST
Is /usr/bin before /usr/sbin in your path
(and before /sbin); if so, you're running
into the pam_console stuff. Having /sbin
and /usr/sbin before /usr/bin in root's path
will fix this.
Comment 2 Riley H Williams 2000-02-09 13:45:59 EST
My understanding is that to avoid problems like this, the correct path prefix
for root is...

    PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin

...but raw installs of RedHat 6.1 appear to vary here depending on precicely
which packages are installed. I haven't managed to isolate this to any
particular package though.

Note You need to log in before you can comment on or make changes to this bug.