Bug 92027 - Memory leak in spell check
Memory leak in spell check
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-31 15:36 EDT by Stephen John Smoogen
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-14 17:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2003-05-31 15:36:41 EDT
Description of problem:

Upstream bug numbers are:
10996
14980

On Sat, 31 May 2003, Mike A. Harris wrote:

>On 31 May 2003, Stephen J Smoogen wrote:
>
>>> >Looking through the logs what I could tell is that the oowriter grew to 
>>> >more memory than there was swap+main-ram (382 combined) on the machine 
>>> >and the kernel began killing things to get more memory. 
>>> >
>>> >Rather cool, but my wife's comment was 'maybe I should edit this in Word 
>>> >from now on.'
>>> 
>>> Sounds like OO has gone hostile on system resources, caused an 
>>> OOM condition in the kernel and some random processes got the axe 
>>> from the kernel.
>>> 
>>> Can you look in your /var/log/messages for VM/OOM errors?
>>
>>That seems to be the case. The kernel reported it killing processes. I
>>did the same steps with the file on my machine with slightly more
>>memory.. and the oowriter grew to 320 megs in size. X similarly grew but
>>I am not sure how much of it is real or virtual. I am guessing between
>>the two of them and cups and other things.. my wifes kernel went into a
>>killing spree.
>
>OO is probably leaking memory and/or X resources.  In the latter 
>case, X resources are stored and arbitrated in the X server, so 
>when resources are leaked, the X server process will increase in 
>size.  Kill the offending process and the X server will shrink.
>
>If you've got a reproduceable testcase, might want to bugzilla 
>against OO.
>

The test case is pretty simple, open any document (any format), misspell
a word and then right click to get alternatives. Watch it begin to leak
memory like a sieve. Keep right clicking and it keeps growing. I got a
1000 word document to grow OO to 800 megs by just having all misspelled
words.

[smooge@glasya Work]$ oowriter LANL.sxw 
Starting OpenOffice.org ...
Hash Manager Error : 1
Error - could not open affix description file 
/usr/lib/openoffice/share/dict/ooo/es_MX.aff
Failure loading aff file /usr/lib/openoffice/share/dict/ooo/es_MX.aff
Error - could not open affix description file 
/usr/lib/openoffice/share/dict/ooo/de_AT.aff
Failure loading aff file /usr/lib/openoffice/share/dict/ooo/de_AT.aff

The Hash error shows up as soon as you right click. It must definately 
be leaking X resources because after quiting OO, X dropped down to its 
normal size.

I will file in the Bugzilla as soon as I have finished downloading the 
1.0.3 and 1.1beta tar balls to see if it might be listed in some sort of 
changelog. 


Version-Release number of selected component (if applicable):

1.0.2.. maybe fixed in 1.0.3.1

How reproducible:

100%

Steps to Reproduce:
1. Make a document with a lot of misspelled words.
2. Right click on words
3. Watch memory go through roof.
Comment 1 Dan Williams 2004-02-27 11:28:17 EST
Should be fixed in RHEL3 U2 with the update to 1.1.0

Note You need to log in before you can comment on or make changes to this bug.