Bug 92036 - (SOUND AC97_CODEC)No sound until I run aumix
(SOUND AC97_CODEC)No sound until I run aumix
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-01 06:33 EDT by Tobias Muhlhofer
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output from lspci -v (3.46 KB, text/plain)
2003-06-05 17:05 EDT, Tobias Muhlhofer
no flags Details

  None (edit)
Description Tobias Muhlhofer 2003-06-01 06:33:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
Sound card: SiS 7018.
Upon booting and logging into an X session or a bash session, no sound is heard.
To fix this, I have to become root and run aumix, change every setting back and
forth, save, and quit. After that, the sound works just fine until I reboot the
next time.

Had the same problem in RH8.

Version-Release number of selected component (if applicable):
All kernels for RH8 and RH9

How reproducible:
Always

Steps to Reproduce:
1.Boot and log in. No sound.
2.Run aumix, change every channel, save, quit.
3.Sound
    

Actual Results:  No sound upon first bootup.

Expected Results:  Sound.

Additional info:

I'm assuming it's a kernel fault.

No idea how to troubleshoot this: what log files do I need to check, etc.?
Comment 1 Alan Cox 2003-06-05 11:28:06 EDT
Two questions:
Does a specifc setting make the difference
What kind of sound card is it (or attach lspci -v if you are not sure)
Comment 2 Tobias Muhlhofer 2003-06-05 17:05:01 EDT
Created attachment 92183 [details]
The output from lspci -v
Comment 3 Tobias Muhlhofer 2003-06-05 17:09:20 EDT
OK, I attached the output from lspci -v.

I tried each setting in aumix. Here's the deal:

If I change the Vol adjustment bash starts beeping (it didn't until then).
When I change the Pcm adjustment the sounds in X work as well (they didn't with
only Vol).

Comment 4 Tobias Muhlhofer 2003-06-05 17:18:42 EDT
Turns out, no other setting makes a difference, alone or in combination. Just
those two as described above.
Comment 5 Bugzilla owner 2004-09-30 11:41:01 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.