Bug 920376 - other Fatal error: Exception down the road , when url got %20
Summary: other Fatal error: Exception down the road , when url got %20
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-review
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-11 23:12 UTC by Sergio Monteiro Basto
Modified: 2013-05-14 17:45 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-03-13 06:04:39 UTC


Attachments (Terms of Use)
traceback (1.45 KB, text/plain)
2013-03-12 06:18 UTC, Sergio Monteiro Basto
no flags Details

Description Sergio Monteiro Basto 2013-03-11 23:12:49 UTC
Description of problem:

I'm trying review package PyPE
I got 
ERROR: Exception down the road...(logs in /home/sergio/.cache/fedora-review.log)
early 

Source0: http://downloads.sourceforge.net/project/pype/pype/PyPE%202.9.4/PyPE-2.9.4-src.zip

Version-Release number of selected component (if applicable):
0.4.0-4.fc18

Actual results:
Exception down the road

Expected results:
no Exception down the road 

Additional info:
while I file this bug I found that : 
 http://downloads.sourceforge.net/project/pype/pype/PyPE 2.9.4/PyPE-2.9.4-src.zip
works 
instead %20 I put a space like we see it on browser. 

So I workaround the problem but this bug report could still valid I don't know.

Comment 1 Pierre-YvesChibon 2013-03-12 06:05:09 UTC
(In reply to comment #0)
>So I workaround the problem but this bug report could still valid I don't know.
Actually, this is not a problem in fedora-review but in parsing the spec file.
Try to build the package in mock and you will see.

In case it does work, having the logs would help, see:
>ERROR: Exception down the road...(logs in /home/sergio/.cache/fedora-review.log)

Comment 2 Sergio Monteiro Basto 2013-03-12 06:18:03 UTC
Created attachment 708773 [details]
traceback

Hi, 
vi /usr/lib/python2.7/site-packages/FedoraReview/spec_file.py
on line 123 

    for (url, num, flags) in self.spec.sources:

If I got url with %20 will traceback in line 127 

    result[tag] = self.spec.sourceHeader.format(url)

I know this kind of error, url can't have % because it will be consider a string format. 
Also works if we put 
url = url.replace('%' ,'%%') 
before 
result[tag] = self.spec.sourceHeader.format(url)

Comment 3 Alec Leamas 2013-03-12 08:57:39 UTC
Sergio: Can you please attach the complete log at ~/.cache/fedora-review so we can reproduce this?

Comment 4 Alec Leamas 2013-03-12 11:07:15 UTC
OK, steps to reproduce:
- yumdownloader --source PyPE
- ./try-fedora-review -rn  PyPE-2.9.1-7.fc18.src.rpm

gives this crash. So: no log needed.

Comment 5 Alec Leamas 2013-03-12 11:56:03 UTC
OK, there's a fix in devel, see http://git.fedorahosted.org/cgit/FedoraReview.git/commit/?id=e854054.

Comment 6 Sergio Monteiro Basto 2013-03-13 06:04:39 UTC
(In reply to comment #5)
> OK, there's a fix in devel, see
> http://git.fedorahosted.org/cgit/FedoraReview.git/commit/?id=e854054.

fine, closing as fixed in next release  

Thanks :)

Comment 7 Fedora Update System 2013-04-29 14:51:40 UTC
fedora-review-0.4.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.4.1-1.fc18

Comment 8 Fedora Update System 2013-04-29 14:52:12 UTC
fedora-review-0.4.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.4.1-1.el6

Comment 9 Fedora Update System 2013-04-29 14:52:40 UTC
fedora-review-0.4.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedora-review-0.4.1-1.fc19

Comment 10 Fedora Update System 2013-04-29 14:53:12 UTC
fedora-review-0.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.4.1-1.fc17

Comment 11 Fedora Update System 2013-05-04 01:42:33 UTC
fedora-review-0.4.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-05-14 17:45:42 UTC
fedora-review-0.4.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.