Bug 920385 - Unable to map the esc key using xsetwacom.
Summary: Unable to map the esc key using xsetwacom.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-wacom
Version: 6.4
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: 6.5
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 960058
TreeView+ depends on / blocked
 
Reported: 2013-03-12 00:51 UTC by Parthasarathi Susarla
Modified: 2018-12-04 15:07 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-drv-wacom-0.16.1-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 07:27:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1568 normal SHIPPED_LIVE xorg-x11-drv-wacom bug fix update 2013-11-20 21:40:03 UTC

Description Parthasarathi Susarla 2013-03-12 00:51:28 UTC
Description of problem:
Unable to map the Escape key to one of the buttons on a Wacom Cintiq 22HD pad. All other modifier keys work (alt/ctrl etc.).

Version-Release number of selected component (if applicable):
xorg-x11-drv-wacom-0.16.1-3.el6.x86_64 on Red Hat Enterprise Linux 6

How reproducible:
Consistent.


Steps to Reproduce:
1. Try and set escape to one of the buttons on the Wacom tablet:
   $ xsetwacom --set "Wacom Cintiq 22HD pad" Button 13 "key  Esc"
The command doesn't return any error, but the key isn't mapped.

  
Actual results:
Running a get results in a null:
$ xsetwacom --get "Wacom Cintiq 22HD pad" Button 13
key +(null) -(null) 

Expected results:
The button on the pad should be mapped to Escape

Additional info:

Output from xev:

KeyPress event, serial 34, synthetic NO, window 0x8600001,
    root 0x1f5, subw 0x0, time 946082789, (89,118), root:(3636,1033),
    state 0x10, keycode 8 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 34, synthetic NO, window 0x8600001,
    root 0x1f5, subw 0x0, time 946082789, (89,118), root:(3636,1033),
    state 0x10, keycode 8 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Comment 1 Peter Hutterer 2013-03-12 04:19:44 UTC
Verified, upstream fix is xf86-input-wacom-0.17.0-3-ge604e4e

Comment 6 Peter Hutterer 2013-07-01 01:54:04 UTC
MODIFIED

xorg-x11-drv-wacom-0.16.1-4.el6 is available in brew

Comment 11 errata-xmlrpc 2013-11-21 07:27:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1568.html


Note You need to log in before you can comment on or make changes to this bug.