Bug 92042 - Bad: "up2date -u" fails to update with "Test install failed because of package conflicts" error using spamassassin-2.55-1.dag.rh90
Bad: "up2date -u" fails to update with "Test install failed because of packag...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-01 15:37 EDT by Alfredo Milani Comparetti
Modified: 2007-04-18 12:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 16:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Milani Comparetti 2003-06-01 15:37:40 EDT
Having installed spamassassin-2.55-1.dag.rh90 and perl-Mail-SpamAssassin-2.55-
1.dag.rh90, executing "up2date -u -vv" says:

D: logininfo: { info removed :-) }
D: add instance class name memcache
D: add instance class name diskcache
D: add instance class name localdisk
D: add instance class name get
D: add instance class name localdisk
D: add instance class name diskcache
D: add instance class name get
D: add instance class name localdisk
D: add instance class name diskcache
D: add instance class name get
D: add instance class name diskcache
D: add instance class name get
D: add instance class name diskcache
D: add instance class name get
D: availablePackageList::channels: [['redhat-linux-i386-
9', '20030530043336', '0', '1']]

Fetching package list for channel: redhat-linux-i386-9...
########################################
D: listPackages Fetched via: diskcache
D: obsoletesList::channels: [['redhat-linux-i386-
9', '20030530043336', '0', '1']]

Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################
D: getObsoletes Fetched via: diskcache
D: archscore 5

Fetching rpm headers...
D: Header for ['spamassassin', '2.44', '11.8.x', '', 'i386', '408929', 'redhat-
linux-i386-9'] Fetched via: diskcache
########################################
D: Called dryRun 
[['spamassassin', '2.44', '11.8.x', '', 'i386', '408929', 'redhat-linux-i386-
9']]
D: obsoletesList::channels: [['redhat-linux-i386-
9', '20030530043336', '0', '1']]
D: getObsoletes Fetched via: diskcache

Testing package set / solving RPM inter-dependencies...
D: Candidates for the selected list: 
[['spamassassin', '2.44', '11.8.x', '', 'i386', '408929', 'redhat-linux-i386-
9']]
D: Adding to transaction set 
['spamassassin', '2.44', '11.8.x', '', 'i386', '408929', 'redhat-linux-i386-9']
D: Selected so far 
[['spamassassin', '2.44', '11.8.x', '', 'i386', '408929', 'redhat-linux-i386-
9']]
D: Checking for dependencies
D: Got code 0 from solvedep
D: Running transaction (final step)...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package spamassassin-2.55-1.dag.rh90 (which is newer than spamassassin-2.44-
11.8.x) is already installed



This error occurs every time I try.
Comment 1 Adrian Likins 2003-06-11 15:59:50 EDT
Looks like an unresolvable depenecies cause by the installation
of the 3rd party spamassassin packages.

Where can I find a copy of those spamassissin packages to
test with? 

My guess is that the perl-Mail-SpamAssassissin package
is causing the problems, since we dont ship a package
by that name, so it cant be updated. This may be causing
the old packages to pull in odd deps. Hard to say without
seeing the third party packages to test.
Comment 2 Alfredo Milani Comparetti 2003-06-11 16:49:23 EDT
You can get those SpamAssassin's packages here:

http://dag.wieers.com/packages/spamassassin/
Comment 3 Dag Wieers 2003-06-21 13:40:01 EDT
The weird thing about this, is that up2date tries to update a newer spamassassin
with an older package. RPM seems to compare both versions fine but up2date doesn't.

This is was apt does. And it would correctly prefer 2.55-2 over any other version.

[dag@lisse ~]# apt-cache policy spamassassin
spamassassin:
  Installed: (none)
  Candidate: 2.55-2.dag.rh90
  Version Table:
     2.55-2.dag.rh90 0
        500 file: redhat/9.0/en/i386/dag pkglist
     2.55-1.dag.rh90 0
        500 file: redhat/9.0/en/i386/dag pkglist
     2.55-0.dag.rh90 0
        500 file: redhat/9.0/en/i386/dag pkglist
     2.44-11.8.x 0
        500 http://apt.ccl.kuleuven.ac.be redhat/9/en/i386/os pkglist
Comment 4 Dale R. Worley 2003-10-03 21:40:59 EDT
I am running into a similar problem with up2date (up2date-3.0.7.2-1 currently
installed) in RHL 8.0.

I created the problem this way:

Install RHL 8.0, upgrade occasionally using up2date.

Update mozilla from 1.0.2 to 1.2.1 by doing the following:

Remove the following packages:

mozilla-1.0.2-2.8.0
mozilla-chat-1.0.2-2.8.0
mozilla-devel-1.0.2-2.8.0
mozilla-dom-inspector-1.0.2-2.8.0
mozilla-js-debugger-1.0.2-2.8.0
mozilla-mail-1.0.2-2.8.0
mozilla-nspr-1.0.2-2.8.0
mozilla-nspr-devel-1.0.2-2.8.0
mozilla-nss-1.0.2-2.8.0
mozilla-nss-devel-1.0.2-2.8.0
mozilla-psm-1.0.2-2.8.0
kdebindings-kmozilla-3.0.5a-2
galeon-1.2.11-1.8.0
plugger-4.0-17
evolution-1.0.8-11

Then add the following packages:

mozilla-1.2.1-26.i386.rpm
mozilla-chat-1.2.1-26.i386.rpm
mozilla-devel-1.2.1-26.i386.rpm
mozilla-dom-inspector-1.2.1-26.i386.rpm
mozilla-js-debugger-1.2.1-26.i386.rpm
mozilla-mail-1.2.1-26.i386.rpm
mozilla-nspr-1.2.1-26.i386.rpm
mozilla-nspr-devel-1.2.1-26.i386.rpm
mozilla-nss-1.2.1-26.i386.rpm
mozilla-nss-devel-1.2.1-26.i386.rpm
mozilla-psm-1.2.1-26.i386.rpm
plugger-4.0-23.i386.rpm
galeon-1.2.7-3.i386.rpm

These packages are described as part of RHL 9 in the RPMfind database
(http://rpmfind.net/linux/rpm2html/search.php?query=mozilla&submit=Search+...&system=red&arch=i386)
and I fetched them from the FTP source listed in that RPMfind listing,
ftp://rpmfind.net/linux/redhat/9/en/os/i386/RedHat/RPMS/.

Mozilla 1.2.1 seems to work fine, though it was built for RHL 9 and I am running
RHL 8.0.  (The Mozilla 1.4 from the RHL 10 betas does *not* work.)

However, the installation seems to break up2date.  When I run up2date, I get the
following output:


[root@dragon etc]# up2date -u

Fetching package list for channel: redhat-linux-i386-8.0...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-8.0...
########################################

Fetching rpm headers...

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package mozilla-nspr-1.2.1-26 (which is newer than mozilla-nspr-1.0.2-2.8.0) is
already installed


It appears that up2date doesn't handle the case when the installed version of a
package is newer than the most recent version up2date has access to.  Since all
of these packages were built as part of RHL, there should be no missing
information in the RPMs themselves.

Worse, I have been unable to figure out how to instruct up2date to just ignore
mozialla-nspr so as to let up2date function for the rest of the system.  I have
tried several things, but the following should have worked:

I used up2date --configure to edit the pkgSkipList to insert "mizilla-nspr-*". 
This left /etc/sysconfig/rhn/up2date with the lines:


pkgSkipList[comment]=A list of package names, optionally including wildcards, to
skip
pkgSkipList=kernel*,iptables*,mozilla-nspr-*;


However, this seems to have no effect on up2date's behavior.  (This may be a
seperate bug, that up2date doesn't process pkgSkipList correctly.)

This bug should be considered rather high priority since it leaves up2date
entirely disabled, which could present a problem if further mandatory security
patches are issued.

Note You need to log in before you can comment on or make changes to this bug.