Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 92049 - dump can't compress to remote tape drive
dump can't compress to remote tape drive
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dump (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-01 23:08 EDT by Damian Menscher
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 17:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Menscher 2003-06-01 23:08:46 EDT
Description of problem:
If dumping to a remote tape drive, compression does not work.  For example 
(I've set the $TAPE and $RSH variables to allow auto-login):

dump -u0 /tmp   # works
dump -u0z /tmp  # does not work
dump -u0j /tmp  # does not work

When compression is enabled, it gives errors along the lines of:
  DUMP: write: Invalid argument
  DUMP: write error 30 blocks into volume 1: Invalid argument
  DUMP: Do you want to rewrite this volume?: ("yes" or "no")   DUMP: write: 
Invalid argument
  DUMP: write: Invalid argument

I'm guessing it's receiving compressed positioning commands, in addition to the 
compressed data.

Note that using compression to a local file works fine.

Version-Release number of selected component (if applicable):
dump-0.4b28-7

How reproducible:
Always

Steps to Reproduce:
1.dump to remote tape using -j or -z

Actual Results:  Dump fails with write errors

Expected Results:  Should have produced a compressed dump on the remote tape

Additional info:

I'm using a Seagate Travan 40 (ATAPI) drive, model STT3401A.
Comment 1 Stelian Pop 2003-06-02 09:23:34 EDT
RTFM:
              This option will work only when
              dumping to a file or pipe or,  when  dumping  to  a
              tape drive, if the tape drive is capable of writing
              variable length blocks.

You will probably have to issue a 'mt setblk 0', if your tape drive works with
this setting.

Stelian.
Comment 2 Mike A. Harris 2003-06-03 17:54:33 EDT
I take the upstream author (Stelian)'s above comment as indicative that
this is not a bug, but misuse of the application.

Closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.