Bug 92084 - Can't create a Multi Part Article. CCM Error
Can't create a Multi Part Article. CCM Error
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity high
: ---
: ---
Assigned To: Rafael H. Schloming
Jon Orris
:
Depends On:
Blocks: 88926
  Show dependency treegraph
 
Reported: 2003-06-02 12:04 EDT by Jon Orris
Modified: 2014-12-01 18:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 12:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-06-02 12:04:24 EDT
Description of problem:
@31895

Try to create an MPA. Get this error.


Notice
An unexpected error has occurred	

An unexpected error has occurred. If this continues to be a problem for you
please contact the administrators of the site quoting the following:

CCM issue report code: localhost:8080:3890f62f:f589449c41

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: localhost:8080:3890f62f:f589449c41 -*-*-*-
-*-*-*- Message: null -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept-Encoding: gzip,deflate,compress;q=0.9
Accept-Language: en-us,en;q=0.5
Connection: keep-alive
Content-Length: 2058
Content-Type: multipart/form-data;
boundary=---------------------------1622597488111537764338888228
Cookie: ad_user_login=9!1147982616736!JEeK1L0irENuwDjltTwipQ==;
JSESSIONID=aVJYZ1noFysf
Host: localhost:8080
Keep-Alive: 300
Referer: http://localhost:8080/ccm/content-center/
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

-*-*-*- Section: Cookies -*-*-*-
ad_user_login: 9!1147982616736!JEeK1L0irENuwDjltTwipQ== (expires: -1)
JSESSIONID: aVJYZ1noFysf (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
java.lang.NullPointerException
	at
com.arsdigita.cms.ContentTypeWorkflowTemplate.getWorkflowTemplate(ContentTypeWorkflowTemplate.java:98)
	at
com.arsdigita.cms.contenttypes.ui.mparticle.MultiPartArticleCreate.process(MultiPartArticleCreate.java:117)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.MetaForm.process(MetaForm.java:164)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:251)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:259)
	at
com.arsdigita.cms.dispatcher.ContentCenterDispatcher.dispatch(ContentCenterDispatcher.java:154)
	at
com.arsdigita.sitenode.SiteNodeDispatcher.doDispatch(SiteNodeDispatcher.java:416)
	at com.arsdigita.sitenode.SiteNodeDispatcher.access$100(SiteNodeDispatcher.java:71)
	at com.arsdigita.sitenode.SiteNodeDispatcher$1.excurse(SiteNodeDispatcher.java:251)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.sitenode.SiteNodeDispatcher.dispatch(SiteNodeDispatcher.java:238)
	at
com.arsdigita.dispatcher.BaseDispatcherServlet.service(BaseDispatcherServlet.java:318)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.QNamedDispatcher.forward(QNamedDispatcher.java:157)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:150)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/content-center/
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
file.encoding: UTF-8
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
/home/boston/jorris/dev/lib/classes12.zip:/home/boston/jorris/dev/lib/junit.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/resin.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jdbc2_0-stdext.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jta-spec1_0_1.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jndi.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/dom.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/sax.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jaxp.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jmx.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/webutil.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jdbc-mysql.jar:/opt/IBMJava2-131/lib/tools.jar:/opt/IBMJava2-131/jre/lib/rt.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jsdk23.jar
java.class.version: 46.0
java.compiler: jitc
java.ext.dirs: /opt/IBMJava2-131/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled: jitc)
java.home: /opt/IBMJava2-131/jre
java.io.tmpdir: /tmp
java.library.path:
/opt/IBMJava2-131/jre/bin:/opt/IBMJava2-131/jre/bin/classic:/product/9.2.0.1/lib:/product/9.2.0.1/ctx/lib:/product/9.2.0.1/JRE/lib/i386/native_threads:/lib:/usr/lib:libexec:/usr/lib
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
org.apache.xalan.processor.TransformerFactoryImpl
line.separator: 

org.xml.sax.driver: org.apache.xerces.parsers.SAXParser
os.arch: x86
os.name: Linux
os.version: 2.4.18-27.8.0
path.separator: :
PreferredXSLTTransformer: XALAN
resin.home: /home/boston/jorris/webserver/resin-2.1.4
sun.boot.class.path:
/opt/IBMJava2-131/jre/lib/rt.jar:/opt/IBMJava2-131/jre/lib/i18n.jar:/opt/IBMJava2-131/jre/classes
sun.boot.library.path: /opt/IBMJava2-131/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /home/boston/jorris/webserver/resin-2.1.4
user.home: /home/boston/jorris
user.language: en
user.name: jorris
user.region: US
user.timezone: America/New_York
vendor: Apache Software Foundation
vendor-url: http://xml.apache.org/xalan
version: 2.1.0
-*-*-*-*-*- End Error Report -*-*-*-*-*-
Comment 1 Richard Li 2003-06-02 13:41:00 EDT
This bug also blocks the testing of ReusableImageAsset merge.
Comment 2 Justin Ross 2003-06-02 16:19:10 EDT
Fixed as part of change 31932.

Change 31932 by justin@justin-spellingbee-acs on 2003/06/02 16:15:25

	       Fixes bz92084 and sdm22809.  For the bugzilla bug, we were trying to
	       get the template for a bundle's content type, which is null.  For the
	       SDM bug, integrates Scott's changes from the London branch, a la
	
	       p4 integrate //ps/apps/london/cms/5.2/...@27579,27579 //cms/dev/...

Affected files ...

...
//cms/dev/src/com/arsdigita/cms/contenttypes/ui/mparticle/MultiPartArticleCreate.java#8
edit
...
//cms/dev/src/com/arsdigita/cms/contenttypes/ui/mparticle/MultiPartArticleViewSections.java#8
integrate
...
//cms/dev/src/com/arsdigita/cms/contenttypes/ui/mparticle/SectionEditForm.java#9
integrate
...
//cms/dev/src/com/arsdigita/cms/contenttypes/ui/mparticle/SectionTable.java#6
integrate
Comment 3 Richard Li 2003-06-02 16:34:09 EDT
I can create the MPA. However, when I add a section and upload an image, I get:

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code:
conundrum.boston.redhat.com:9006:3222d440:f58a3aa962 -*-*-*-
-*-*-*- Message:  (root cause: ERROR:  ct_mp_sections_text_f_hx6oy referential
integrity violation - key referenced from ct_mp_sections not found in cms_text
) -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept-Encoding: gzip,deflate,compress;q=0.9
Accept-Language: en-us,en;q=0.5
Connection: keep-alive
Content-Length: 6072
Content-Type: multipart/form-data;
boundary=---------------------------1566487940195200155728210737
Cookie: JSESSIONID=aNbnSM7UcHP-;
ad_user_login=24001!1149190942076!aG5gHa704MDaQWON4I34/Q==
Host: conundrum.boston.redhat.com:9006
Keep-Alive: 300
Referer:
http://conundrum.boston.redhat.com:9006/ccm/content/admin/item.jsp?bbp.1451.sel=6062&bbp.97.row=27013&bbp.1232.sel=6052&bbp.3.pane=1&bbp.1054.sel=6043&bbp.2463.d=asc&bbp.876.sel=6034&bbp.972.sel=6039&bbp.214.sel=6023&bbp.410.sel=6029&bbp.1131.sel=6047&bbp.s=144&item_id=27001&bbp.i=17vqr5l082v6vear4t9acswc9l2pepq13dhz341mvgvt63jxpjxl96ncq785vmlk04u8vrsbvjitlkjn2u1jx37tct2vx8n6v6bbg4myszcd6y86hx46fsny18r0frbmwsen2s7angjg2rvlt0zu4p803io5x1bc3muvh47orwfgi033db4ipbgd6nsmpb9xthuiiv5282zjj0qo721r7h3wotmjqq0rgn40q8o6wu5larah0r3gg7r544dckyssdzg746r4akge3im6cbd69kslahxv7pc2xcwrtjq69l4boda67a35m23pzyi4a81yz5sx3viu4twpvhdvli5wwizqxlzybefkcc8y7mlaie5chzee6bcczalykrzfgzpo9byqgrszeims58wiyxzto7nx6gvluu6eo0h2wtxf8yoobwo5xf8ni0r0mshchrs3034yaueltuxvxkzwi2bu03oys7o0&bbp.31.sel=6014&bbp.1345.sel=6057&bbp.106.sel=6019&bbp.1937.sel=6068&bbp.2211.d=asc&bbp.97.col=1&bbp.2031.sel=6073&g11n.enc=ISO-8859-1&bbp.2476.d=asc
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516
Mozilla Firebird/0.6

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: aNbnSM7UcHP- (expires: -1)
ad_user_login: 24001!1149190942076!aG5gHa704MDaQWON4I34/Q== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.persistence.PersistenceException:  (root cause:
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine$3: ERROR: 
ct_mp_sections_text_f_hx6oy referential integrity violation - key referenced
from ct_mp_sections not found in cms_text
)
	at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:365)
	at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
	at
com.arsdigita.cms.contenttypes.ui.mparticle.SectionEditForm.process(SectionEditForm.java:284)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:251)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:259)
	at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java:59)
	at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
	at com.caucho.jsp.Page.subservice(Page.java:485)
	at com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:174)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:203)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:216)
	at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:61)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:142)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)
Root cause: 
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine$3: ERROR: 
ct_mp_sections_text_f_hx6oy referential integrity violation - key referenced
from ct_mp_sections not found in cms_text

	at
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:477)
	at
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:435)
	at
com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.flush(RDBMSEngine.java:396)
	at com.arsdigita.persistence.proto.Session.flushInternal(Session.java(Compiled
Code))
	at com.arsdigita.persistence.proto.Session.flush(Session.java:476)
	at com.arsdigita.persistence.proto.Cursor.next(Cursor.java:94)
	at com.arsdigita.persistence.proto.Session.retrieve(Session.java:56)
	at com.arsdigita.persistence.Session.retrieve(Session.java:535)
	at com.arsdigita.x.versioning.Event.getDataObject(Event.java:67)
	at com.arsdigita.x.versioning.DataObjectChange.record(DataObjectChange.java:164)
	at
com.arsdigita.x.versioning.DataObjectChange.recordEvent(DataObjectChange.java:144)
	at
com.arsdigita.x.versioning.VersioningEventProcessor$EventSwitch.onSet(VersioningEventProcessor.java:101)
	at com.arsdigita.persistence.proto.SetEvent.dispatch(SetEvent.java(Compiled Code))
	at
com.arsdigita.x.versioning.VersioningEventProcessor.write(VersioningEventProcessor.java:66)
	at com.arsdigita.persistence.proto.Session.flushInternal(Session.java(Compiled
Code))
	at com.arsdigita.persistence.proto.Session.flush(Session.java:476)
	at com.arsdigita.persistence.proto.Cursor.next(Cursor.java:94)
	at com.arsdigita.persistence.proto.Session.retrieve(Session.java:56)
	at com.arsdigita.persistence.Session.retrieve(Session.java:535)
	at com.arsdigita.x.versioning.Event.getDataObject(Event.java:67)
	at
com.arsdigita.x.versioning.DataObjectChange.recordEvent(DataObjectChange.java:176)
	at
com.arsdigita.x.versioning.VersioningEventProcessor$EventSwitch.onCreate(VersioningEventProcessor.java:120)
	at com.arsdigita.persistence.proto.CreateEvent.dispatch(CreateEvent.java:24)
	at
com.arsdigita.x.versioning.VersioningEventProcessor.write(VersioningEventProcessor.java:66)
	at com.arsdigita.persistence.proto.Session.flushInternal(Session.java(Compiled
Code))
	at com.arsdigita.persistence.proto.Session.flush(Session.java:476)
	at com.arsdigita.persistence.proto.Cursor.next(Cursor.java:94)
	at com.arsdigita.persistence.proto.Session.retrieve(Session.java:56)
	at com.arsdigita.persistence.Session.retrieve(Session.java:535)
	at com.arsdigita.x.versioning.Event.getDataObject(Event.java:67)
	at com.arsdigita.x.versioning.DataObjectChange.record(DataObjectChange.java:164)
	at
com.arsdigita.x.versioning.DataObjectChange.recordEvent(DataObjectChange.java:144)
	at
com.arsdigita.x.versioning.VersioningEventProcessor$EventSwitch.onSet(VersioningEventProcessor.java:101)
	at com.arsdigita.persistence.proto.SetEvent.dispatch(SetEvent.java(Compiled Code))
	at
com.arsdigita.x.versioning.VersioningEventProcessor.write(VersioningEventProcessor.java:66)
	at com.arsdigita.persistence.proto.Session.flushInternal(Session.java(Compiled
Code))
	at com.arsdigita.persistence.proto.Session.flush(Session.java:476)
	at com.arsdigita.persistence.proto.Cursor.next(Cursor.java:94)
	at com.arsdigita.persistence.proto.Session.retrieve(Session.java:56)
	at com.arsdigita.persistence.Session.retrieve(Session.java:535)
	at com.arsdigita.x.versioning.Event.getDataObject(Event.java:67)
	at com.arsdigita.x.versioning.DataObjectChange.record(DataObjectChange.java:164)
	at
com.arsdigita.x.versioning.DataObjectChange.recordEvent(DataObjectChange.java:144)
	at
com.arsdigita.x.versioning.VersioningEventProcessor$EventSwitch.onSet(VersioningEventProcessor.java:101)
	at com.arsdigita.persistence.proto.SetEvent.dispatch(SetEvent.java(Compiled Code))
	at
com.arsdigita.x.versioning.VersioningEventProcessor.write(VersioningEventProcessor.java:66)
	at com.arsdigita.persistence.proto.Session.flushInternal(Session.java(Compiled
Code))
	at com.arsdigita.persistence.proto.Session.flush(Session.java:476)
	at com.arsdigita.persistence.proto.Cursor.next(Cursor.java:94)
	at com.arsdigita.persistence.DataQueryImpl.next(DataQueryImpl.java:443)
	at com.arsdigita.domain.DomainQuery.next(DomainQuery.java:84)
	at com.arsdigita.cms.ContentType.findByAssociatedObjectType(ContentType.java:331)
	at com.arsdigita.cms.ContentItem.beforeSave(ContentItem.java:367)
	at com.arsdigita.domain.DomainObject$SaveObserver.beforeSave(DomainObject.java:611)
	at com.arsdigita.persistence.BeforeSaveEvent.doInvoke(DataEvent.java:169)
	at com.arsdigita.persistence.DataEvent.invoke(DataEvent.java:39)
	at
com.arsdigita.persistence.DataObjectImpl.fireObserver(DataObjectImpl.java(Compiled
Code))
	at com.arsdigita.persistence.DataEvent.fire(DataEvent.java:48)
	at com.arsdigita.persistence.Session$FlushEventProcessor.fireNow(Session.java:338)
	at com.arsdigita.persistence.DataObjectImpl.save(DataObjectImpl.java:355)
	at com.arsdigita.domain.DomainObject.save(DomainObject.java:315)
	at
com.arsdigita.cms.contenttypes.ui.mparticle.SectionEditForm.process(SectionEditForm.java:284)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:444)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:418)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java:345)
	at com.arsdigita.bebop.Form.process(Form.java:431)
	at com.arsdigita.bebop.Form.respond(Form.java:276)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:251)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:259)
	at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java:59)
	at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
	at com.caucho.jsp.Page.subservice(Page.java:485)
	at com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:174)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:203)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:216)
	at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:61)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:142)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:128)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:104)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:238)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
	at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/content/admin/item.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
file.encoding: ISO-8859-1
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
:/var/ccm-devel/web/richardl/cms/webapps/ccm/WEB-INF/lib/jaas.jar:/var/ccm-devel/web/richardl/cms/webapps/ccm/WEB-INF/lib/jce.jar:/var/ccm-devel/web/richardl/cms/webapps/ccm/WEB-INF/lib/sunjce_provider.jar:/opt/oracle/product/9.2.0.1/jdbc/lib/classes12.zip:/var/ccm-devel/web/richardl/cms/webapps/ccm/WEB-INF/lib/xerces.jar:/var/ccm-devel/web/richardl/cms/webapps/ccm/WEB-INF/lib/xalan.jar:/opt/resin/2.1.4/lib/jaxp.jar:/opt/resin/2.1.4/lib/dom.jar:/opt/resin/2.1.4/lib/jdbc2_0-stdext.jar:/opt/resin/2.1.4/lib/jdbc-mysql.jar:/opt/resin/2.1.4/lib/jndi.jar:/opt/resin/2.1.4/lib/jmx.jar:/opt/resin/2.1.4/lib/jta-spec1_0_1.jar:/opt/resin/2.1.4/lib/resin.jar:/opt/resin/2.1.4/lib/sax.jar:/opt/resin/2.1.4/lib/webutil.jar:/opt/IBMJava2-131/lib/tools.jar:/opt/IBMJava2-131/jre/lib/rt.jar:/opt/resin/2.1.4/lib/jsdk23.jar
java.class.version: 46.0
java.compiler: jitc
java.ext.dirs: /opt/IBMJava2-131/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20020302 (JIT enabled: jitc)
java.home: /opt/IBMJava2-131/jre
java.io.tmpdir: /tmp
java.library.path:
/opt/IBMJava2-131/jre/bin:/opt/IBMJava2-131/jre/bin/classic:/opt/oracle/product/9.2.0.1/lib:/lib:/usr/lib:/usr/local/lib:/usr/oracle/JRE/lib:libexec:/usr/lib
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20020302 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
org.apache.xalan.processor.TransformerFactoryImpl
line.separator: 

org.xml.sax.driver: org.apache.xerces.parsers.SAXParser
os.arch: x86
os.name: Linux
os.version: 2.4.9-e.12
path.separator: :
PreferredXSLTTransformer: XALAN
resin.home: /opt/resin/2.1.4
sun.boot.class.path:
/opt/IBMJava2-131/jre/lib/rt.jar:/opt/IBMJava2-131/jre/lib/i18n.jar:/opt/IBMJava2-131/jre/classes
sun.boot.library.path: /opt/IBMJava2-131/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /opt/resin/2.1.4
user.home: /home/boston/richardl
user.language: en
user.name: richardl
user.region: US
user.timezone: America/New_York
vendor: Apache Software Foundation
vendor-url: http://xml.apache.org/xalan
version: 2.1.0
-*-*-*-*-*- End Error Report -*-*-*-*-*-
Comment 4 Richard Li 2003-06-02 16:36:21 EDT
I think that the above only happens IF you create a new section with body text
AND upload an image. It doesn't appear if you just create something with the
body text.
Comment 5 Jon Orris 2003-06-10 12:09:10 EDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.