Bug 920926 - npm packege depency again broken
Summary: npm packege depency again broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: npm
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: T.C. Hollingsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 920929
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-13 05:44 UTC by Mikhail
Modified: 2013-04-17 22:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-17 22:43:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Mikhail 2013-03-13 05:44:07 UTC
Description of problem:
# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package npm.noarch 0:1.2.10-2.fc18 will be updated
---> Package npm.noarch 0:1.2.14-1.fc18 will be an update
--> Processing Dependency: npm(chmodr) < 0.2 for package: npm-1.2.14-1.fc18.noarch
--> Processing Dependency: npm(npm-registry-client) >= 0.2.18 for package: npm-1.2.14-1.fc18.noarch
--> Processing Dependency: npm(node-gyp) >= 0.8.5 for package: npm-1.2.14-1.fc18.noarch
--> Processing Dependency: npm(minimatch) >= 0.2.11 for package: npm-1.2.14-1.fc18.noarch
--> Processing Dependency: npm(glob) >= 3.1.21 for package: npm-1.2.14-1.fc18.noarch
--> Processing Dependency: npm(chmodr) >= 0.1.0 for package: npm-1.2.14-1.fc18.noarch
--> Finished Dependency Resolution
Error: Package: npm-1.2.14-1.fc18.noarch (updates-testing)
           Requires: npm(chmodr) >= 0.1.0
Error: Package: npm-1.2.14-1.fc18.noarch (updates-testing)
           Requires: npm(minimatch) >= 0.2.11
           Installed: nodejs-minimatch-0.2.9-2.fc18.noarch (@updates-testing)
               npm(minimatch) = 0.2.9
Error: Package: npm-1.2.14-1.fc18.noarch (updates-testing)
           Requires: npm(glob) >= 3.1.21
           Installed: nodejs-glob-3.1.20-1.fc18.noarch (@updates-testing)
               npm(glob) = 3.1.20
Error: Package: npm-1.2.14-1.fc18.noarch (updates-testing)
           Requires: npm(chmodr) < 0.2
Error: Package: npm-1.2.14-1.fc18.noarch (updates-testing)
           Requires: npm(npm-registry-client) >= 0.2.18
           Installed: nodejs-npm-registry-client-0.2.15-1.fc18.noarch (@updates-testing)
               npm(npm-registry-client) = 0.2.15
Error: Package: npm-1.2.14-1.fc18.noarch (updates-testing)
           Requires: npm(node-gyp) >= 0.8.5
           Installed: node-gyp-0.8.4-1.fc18.noarch (@updates-testing)
               npm(node-gyp) = 0.8.4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 T.C. Hollingsworth 2013-03-13 06:17:32 UTC
In addition to the others which will soon be fixed, this version of npm adds a new module dependency which will need to be packaged (bug 920929). :-(

I'll back out this update soon so as to unbreak updates-testing, but hopefully this will get back in properly soon.

Comment 2 Eric 2013-04-17 19:52:35 UTC
Trying to install npm-1.2.17-4 from EPEL testing gives me this:

--> Finished Dependency Resolution
Error: Package: npm-1.2.17-4.el6.noarch (epel-6-testing-x86_64)
           Requires: npm(chmodr) < 0.2
Error: Package: npm-1.2.17-4.el6.noarch (epel-6-testing-x86_64)
           Requires: npm(chmodr) >= 0.1.0
Error: Package: nodejs-request-2.16.6-3.el6.noarch (epel-6-testing-x86_64)
           Requires: npm(cookie-jar) < 0.3
Error: Package: nodejs-request-2.16.6-3.el6.noarch (epel-6-testing-x86_64)
           Requires: npm(cookie-jar) >= 0.2.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 3 T.C. Hollingsworth 2013-04-17 22:43:30 UTC
This bug applied to Fedora and was fixed.  I'm aware of the EPEL issue and it should get fixed in the next epel-testing push.


Note You need to log in before you can comment on or make changes to this bug.