Bug 921064 - RFE: TPROXY support for the new haproxy package
RFE: TPROXY support for the new haproxy package
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: haproxy (Show other bugs)
6.4
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ryan O'Hara
Brandon Perkins
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-13 08:20 EDT by Matthias Hensler
Modified: 2013-11-21 06:27 EST (History)
5 users (show)

See Also:
Fixed In Version: haproxy-1.4.24-1.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:27:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Hensler 2013-03-13 08:20:08 EDT
Description of problem:
RHEL 6.4 introduces haproxy as technology preview. With RHEL 6.3 and older the haproxy-package was provided by EPEL.

However, while the EPEL-package did provide TPROXY support, the new package from RHEL does not.

Version-Release number of selected component (if applicable):
1.4.22-3.el6

If possible new haproxy-packages should be provide TPROXY support. To do so the parameter "USE_LINUX_TPROXY=1" is needed in the buildprocess of the package.
Comment 2 Ryan O'Hara 2013-03-19 12:20:00 EDT
I believe TPROXY was not enabled because the build target is set to "linux26". This should probably be set to "linux2628", which would cause USE_LINUX_TPROXY to be implicit.
Comment 3 Paul Wouters 2013-04-06 19:17:28 EDT
I just ran into this too. please add USE_LINUX_TPROXY=1 to the make line.

Thanks
Comment 10 michal novacek 2013-09-03 03:50:17 EDT
I have verified that there is TARGET = linux2628 which makes USE_TPROXY=1 implicit: 

# rpm -q haproxy
haproxy-1.4.24-2.el6.x86_64

# /usr/sbin/haproxy -vv
HA-Proxy version 1.4.24 2013/06/17
Copyright 2000-2013 Willy Tarreau <w@1wt.eu>

Build options :
  TARGET  = linux2628
  CPU     = generic
  CC      = gcc
  CFLAGS  = -O2 -g -fno-strict-aliasing
  OPTIONS = USE_REGPARM=1 USE_PCRE=1

Default settings :
  maxconn = 2000, bufsize = 16384, maxrewrite = 8192, maxpollevents = 200

Encrypted password support via crypt(3): yes

Available polling systems :
     sepoll : pref=400,  test result OK
      epoll : pref=300,  test result OK
       poll : pref=200,  test result OK
     select : pref=150,  test result OK
Total: 4 (4 usable), will use sepoll.
Comment 11 errata-xmlrpc 2013-11-21 06:27:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1619.html

Note You need to log in before you can comment on or make changes to this bug.