Bug 92107 - Missing file in postgresql-libs
Missing file in postgresql-libs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-02 15:08 EDT by John Gorman
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-02 16:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Gorman 2003-06-02 15:08:40 EDT
Description of problem:

Missing file /usr/lib/libpq.so.2.0 from postgresql-libs package.

Version-Release number of selected component (if applicable):

postgresql-libs-7.3.2-3.i386.rpm

How reproducible:

Easy

Steps to Reproduce:

1. rpm -i postgresql-libs-7.3.2-3.i386.rpm
2. rpm -V postgresql-libs
    
Actual results:

missing    /usr/lib/libpq.so.2.0

Expected results:


Additional info:
Comment 1 Andrew Overholt 2003-06-02 16:00:29 EDT
libpq.so.2 is for PostgreSQL <= 7.2.  PostgreSQL >= 7.3 uses libpq.so.3
(provided with the 7.3 packages).  If you need the older library, install
postgresql72-libs (available via up2date).
Comment 2 Damian Menscher 2003-08-03 22:00:50 EDT
Maybe I'm dumb, but why does the RPM think it has the file, when it doesn't?  I 
can understand having a different RPM provide the file, but having postsql-libs 
*think* it provides it when it doesn't seems wrong.
Comment 3 Andrew Overholt 2003-08-05 15:28:19 EDT
I don't understand what you're asking.
Comment 4 Damian Menscher 2003-08-07 01:34:08 EDT
The RPM tells the database that it is installing /usr/lib/libpq.so.2.0, but it
doesn't install that file.  Therefore when checking that installed files match
what's in the database, it comes up as missing.

We're not complaining that the file is NOT installed, since that's the correct
behavior (since it's provided by another package).  The bug is that the database
thinks the file HAS been installed.

Hopefully this is more clear?

Note You need to log in before you can comment on or make changes to this bug.