Bug 921194 - [tomcat] Connectors are not properly discovered and therefore are unavailable along with all their content
[tomcat] Connectors are not properly discovered and therefore are unavailable...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: JON Plugin (Show other bugs)
2.0.0
All All
unspecified Severity urgent
: ---
: 2.0.1
Assigned To: Jean-frederic Clere
Pavel Slavicek
:
: 865488 (view as bug list)
Depends On: 707349
Blocks: 956987 956990
  Show dependency treegraph
 
Reported: 2013-03-13 12:45 EDT by Larry O'Leary
Modified: 2014-08-08 00:22 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to an issue in the JBoss Enterprise Web Server plug in, the connectors <literal>?-8080</literal> and <literal>?-8009</literal> are down. As a result, Tomcat 7 can not be monitored or managed. The bug in the JBoss Enterprise Web Server plug in is now fixed. As a result, the connectors are now discoverable and are named <literal>http-bio-8080</literal> and <literal>ajp-bio-8009</literal> as expected and Tomcat 7 can be managed and monitored successfully.
Story Points: ---
Clone Of: 921191
Environment:
Last Closed: 2014-01-03 07:58:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 330763 None None None Never

  None (edit)
Description Larry O'Leary 2013-03-13 12:45:08 EDT
+++ This bug was initially created as a clone of JBoss ON Bug #921191 +++

Description of problem:
Tomcat 7 can not be monitored/managed due to the connectors failing to be properly discovered and configured.

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Configure Tomcat 7 from EWS 2.0 for management from JBoss ON
2.  Start Tomcat 7 from EWS 2.0.
3.  Start JON 3.1.2.
4.  Import Tomcat 7 instance into JON inventory.
  
Actual results:
Connectors are DOWN and their names are ?-8080 and ?-8009. 

Expected results:
Connectors should be up and have the names http-bio-8080 and ajp-bio-8009.
Comment 6 Larry O'Leary 2013-04-12 13:36:49 EDT
*** Bug 865488 has been marked as a duplicate of this bug. ***
Comment 7 Libor Fuka 2013-05-10 08:53:59 EDT
Verified with Tomcat plugin brew build [1] and EWS 2.0.1.ER1 Tomcat7, Tomcat6 and EWS 1.0.2 GA T5, T6 - RHEL, Windows, Solaris
[1] https://brewweb.devel.redhat.com//buildinfo?buildID=269954

Some new bugs found 961253 (EWS 1.0.2 Tomcat5 - possible Tomcat 5 bug) and 
AJP Tomcat connector name is displayed ajp-xxx in RHEL, MS Windows and Solaris Intel, but on Solaris SPARC the name is displayed like jk-xxxx in JON UI.
It should be the same for all platforms.
Comment 8 Mandar Joshi 2013-05-14 02:25:44 EDT
Added DocText.

@Wei Nan Li, can you please review the Doc Text content?
Comment 9 Mandar Joshi 2013-05-14 02:49:24 EDT
oops..

@Jean-Frederic Clere,  can you please review the Doc Text content?
Comment 10 Jean-frederic Clere 2013-05-14 04:34:23 EDT
"Cause: Tomcat 7 can not be monitored/managed due to the connectors failing to be properly discovered and configured.

Consequence: Connectors are DOWN and their names are ?-8080 and ?-8009

Fix: The bug in the JBoss Enterprise Web Server plugin has now been fixed.

Result: The connectors are now up and have the names http-bio-8080 and ajp-bio-8009. Tomcat 7 can now be monitored/managed successfully."

Looks Ok.
Comment 11 Libor Fuka 2013-05-15 06:21:29 EDT
I reviewed again all Solaris SPARC and Intel JON plugin test runs and here are the results:
EWS 2.0.1 ER1 T6, T7 on Solaris Intel(32 and 64 bits) and on Solaris SPARC - connector names in JON UI are correct ajp-, http-

EWS 1.0.2 GA T5, T6 on Solaris Intel(32 and 64 bits) - connector names in JON UI are correct ajp-, http-
EWS 1.0.2 GA T5, T6 on Solaris SPARC - connector name has jk- instead of ajp-
Comment 12 Libor Fuka 2013-05-15 07:10:24 EDT
It was typo bug in test automation.
This bug is verified.

Note You need to log in before you can comment on or make changes to this bug.