Bug 921294 - dnf downgrade failure
dnf downgrade failure
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-13 18:37 EDT by Rahul Sundaram
Modified: 2014-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: dnf-0.3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-22 09:52:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2013-03-13 18:37:46 EDT
Description of problem:

#dnf downgrade yum
Setting up Downgrade Process
Resolving Dependencies
--> Starting dependency resolution
--> Finished dependency resolution
Error: cannot install both yum-3.4.3-51.fc18.noarch and yum-3.4.3-47.fc18.noarch

using yum works:

#yum downgrade yum
Resolving Dependencies
--> Running transaction check
---> Package yum.noarch 0:3.4.3-51.fc18 will be a downgrade
---> Package yum.noarch 0:3.4.3-75.fc19 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch             Version                 Repository         Size
================================================================================
Downgrading:
 yum           noarch           3.4.3-51.fc18           updates           1.1 M

Transaction Summary
================================================================================
Downgrade  1 Package

Total download size: 1.1 M
Is this ok [y/N]: y
Downloading packages:
yum-3.4.3-51.fc18.noarch.rpm                               | 1.1 MB   00:02     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : yum-3.4.3-51.fc18.noarch                                     1/2 
  Cleanup    : yum-3.4.3-75.fc19.noarch                                     2/2 
  Verifying  : yum-3.4.3-51.fc18.noarch                                     1/2 
  Verifying  : yum-3.4.3-75.fc19.noarch                                     2/2 

Removed:
  yum.noarch 0:3.4.3-75.fc19                                                    

Installed:
  yum.noarch 0:3.4.3-51.fc18            



dnf --version
0.2.22
  Installed: dnf-0:0.2.22-1.git97180b8.fc18.noarch at 2013-03-02 18:02
  Built    : Fedora Project at 2013-03-02 09:40

  Installed: rpm-0:4.10.3.1-1.fc18.x86_64 at 2013-02-09 03:26
  Built    : Fedora Project at 2013-02-06 09:54
Comment 1 Ales Kozumplik 2013-03-22 09:52:39 EDT
Addressed by 0572123, the fix will be included in dnf-0.3.1.

This will only make F19 and beyond DNF versions.
Comment 2 Rahul Sundaram 2013-03-22 15:53:41 EDT
Considering, dnf is experimental at this point, wouldn't you want to push the latest version to all branches to maximize exposure and feedback?  I can pull in the F19 version to confirming the fix but it would be better if you didn't have a F18 specific branch IMO
Comment 3 Ales Kozumplik 2013-03-25 04:24:23 EDT
(In reply to comment #2)
> Considering, dnf is experimental at this point, wouldn't you want to push
> the latest version to all branches to maximize exposure and feedback?  I can
> pull in the F19 version to confirming the fix but it would be better if you
> didn't have a F18 specific branch IMO

I was giving this a lot of thought but ultimately, because of the big move to librepo in F19 versions and despite the experimental state of DNF, people on F18 could be very confused by possible new tracebacks and unexpected behaviors.

Note You need to log in before you can comment on or make changes to this bug.