Bug 92131 - nautilus closes ( crashes?) on mouse movements.
nautilus closes ( crashes?) on mouse movements.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: nautilus (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-02 21:11 EDT by sean
Modified: 2015-01-07 19:05 EST (History)
2 users (show)

See Also:
Fixed In Version: 92053
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 10:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2003-06-02 21:11:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030531

Description of problem:
When you make any mouse movements on nautilus, it closes. It stays up if  you
use keyboard short-cuts ( or if you do nothing).

There are no error messages. If you start in a terminal, it just closes. Nothing
in /var/log/messages.  

I updated  all the stuff from rawhide:

eel2-2.2.4-2
gnome-session-2.2.2-1
metacity-2.4.55-2


I have the same problem with gedit. 

Sean

Version-Release number of selected component (if applicable):
nautilus-2.2.4-2

How reproducible:
Always

Steps to Reproduce:
1.open nautilus
2.move mouse
3.
    

Additional info:
Comment 1 Alexander Larsson 2003-06-03 03:34:16 EDT
Can you run nautilus in gdb for me?

make sure nautilus isn't running, and then run:
gdb nautilus
run
<wait for crash>
bt

Comment 2 sean 2003-06-03 20:38:59 EDT
OK. 

This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)...
(gdb) run
Starting program: /usr/bin/nautilus
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1088072416 (LWP 1435)]
[New Thread 1099754960 (LWP 1442)]
[New Thread 1108147664 (LWP 1443)]
[New Thread 1116700112 (LWP 1446)]
[New Thread 1125092816 (LWP 1447)]
[New Thread 1133485520 (LWP 1448)]
[New Thread 1141878224 (LWP 1449)]
[New Thread 1150270928 (LWP 1450)]
[New Thread 1158663632 (LWP 1451)]
[New Thread 1167056336 (LWP 1452)]
[New Thread 1175449040 (LWP 1453)]
 
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1088072416 (LWP 1435)]
0x407e8502 in pango_layout_get_item_properties ()
   from /usr/lib/libpango-1.0.so.0

I have pango-1.2.2-1. The SIGSEGV seems real - tried it three times .Same result.

Then I went back to pango-1.2.1-3. It works fine now.

So - it seems it's the new pango.

sean
Comment 3 Alexander Larsson 2003-06-04 04:42:29 EDT
Owen, I haven't looked at this yet, but do you know what could cause this?
Comment 4 Alexander Larsson 2003-06-04 08:54:38 EDT
Using pango 1.2.2-2 doesn't give me this problem. Can you try that too jay?
Comment 5 Owen Taylor 2003-06-04 10:22:38 EDT
pango-1.2.2-1 was broken; there's a 1.2.2-2 there now.
Comment 6 sean 2003-06-04 17:28:36 EDT
Used pango-1.2.2-2. Works now.

jay

Note You need to log in before you can comment on or make changes to this bug.