Bug 92141 - nano does not BuildRequire gpm-devel
Summary: nano does not BuildRequire gpm-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: nano   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-03 08:12 UTC by Warren Togami
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 22:35:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2003-06-03 08:12:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
nano-1.2.1-2 in Rawhide has:
BuildPrereq:    ncurses-devel gpm-devel

[temp1@build-rh80 BUILD]$ pwd
/home/temp1/redhat/BUILD
[temp1@build-rh80 BUILD]$ cd nano-1.2.1/
[temp1@build-rh80 nano-1.2.1]$ grep -r "gpm" *
[temp1@build-rh80 nano-1.2.1]$
BuildRequires gpm-devel seems unnecessary.  No "gpm" string anywhere in the
tarball, and build is successful without gpm-devel installed.  Perhaps remove
gpm-devel BuildRequires?

FYI:
This doesn't matter much for this particular report, but Prereq and BuildPrereq
are deprecated in rpm.  They still work though.

Version-Release number of selected component (if applicable):
nano-1.2.1-2

Comment 1 Bill Nottingham 2003-07-24 22:35:30 UTC
I believe it was added because ncurses-devel doesn't require gpm-devel, even
though it's linked against it. But it doesn't make much sense now. Removed, will
be in future builds.


Note You need to log in before you can comment on or make changes to this bug.