Bug 921467 - geome fails with "Unexected failure while determing location" - discontinued API ?
Summary: geome fails with "Unexected failure while determing location" - discontinued ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geome   
(Show other bugs)
Version: 18
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-14 09:35 UTC by Martin Kolman
Modified: 2013-10-31 17:25 UTC (History)
1 user (show)

Fixed In Version: geome-2.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 05:01:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Kolman 2013-03-14 09:35:33 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install geome
2.start geome from command line by typing "geome"
  
Actual results:
"Unexected failure while determing location"

Expected results:
geographic coordinates are returned

Additional info:

From examining the source code, this error might be caused by Google shutting down the Gears WiFi location API[1].

They do provide an alternative API, which seems to be quite limited by the maximum number of 100 queries per API key per day[2]. 

Looks like the Google Maps website is also using some sort of WiFi location API (without needing the user to register for an API key) - maybe that can be used ?

Or maybe Skyhook ?

[1] http://code.google.com/p/gears/wiki/GeolocationAPI
[2] https://developers.google.com/maps/documentation/business/geolocation/
[3] https://maps.google.com/
[4] http://www.skyhookwireless.com/

Comment 1 Paul Wouters 2013-03-14 15:32:23 UTC
Yes that's the reason. I hadn't found an alternative service yet that comes with the right license.

Last I looked, the Google Maps API could only be used for displaying locations on google maps, so we cannot use that.

Skyhook requires a commercial license as well.

There were some openstreetmaps like alternatives trying to build up, but I don't think there is anything usable yet.

Comment 2 Martin Kolman 2013-10-04 12:26:10 UTC
Looks like the GeoClue library is using some sort of WiFi location API:
http://cgit.freedesktop.org/geoclue/tree/src/geoip-server/geoip-lookup.c#n36
http://cgit.freedesktop.org/geoclue/tree/src/geoip-server/geoip-lookup.c#n358

Comment 3 Paul Wouters 2013-10-04 16:21:21 UTC
Those links show:


#define WIFI_LOOKUP_BASE_URI "https://maps.googleapis.com/maps/api/browserlocation/json?browser=firefox&sensor=true"

So it is still the google api. However, reading up on their terms of services now seem to indicate one is allowed to use them:

https://developers.google.com/maps/faq#tos

"The Maps API is available for all sites that are accessible to consumers without charge. You can use the Google Maps APIs on both commercial and non-profit websites as long as your site meets the Terms of Service. "

I will update geome shortly. Thanks for the pointer

Comment 4 Fedora Update System 2013-10-10 15:51:18 UTC
geome-2.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/geome-2.0-1.fc19

Comment 5 Fedora Update System 2013-10-10 15:52:22 UTC
geome-2.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/geome-2.0-1.fc18

Comment 6 Fedora Update System 2013-10-10 15:54:27 UTC
geome-2.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/geome-2.0-1.el6

Comment 7 Fedora Update System 2013-10-10 18:32:16 UTC
Package geome-2.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing geome-2.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11783/geome-2.0-1.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-10-22 05:01:28 UTC
geome-2.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-10-22 05:01:41 UTC
geome-2.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-10-31 17:25:28 UTC
geome-2.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.