Bug 921476 - Please document rule6-* files inside the initscripts documentation
Please document rule6-* files inside the initscripts documentation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.4
All Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-14 05:52 EDT by Michal Bruncko
Modified: 2016-11-25 08:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Documentation does not mention rule-* files. Consequence: Users are not aware of setting routing rules for ipv6 Fix: Document rule6-* files in sysconfic.txt Result: Users can find information about rule6-* files
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:11:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Bruncko 2013-03-14 05:52:47 EDT
Description of problem:
I've just configured policy routing for IPv6 and I've looked for rule-* equivalent for IPv6. I decide to look inside the documentation file "/usr/share/doc/initscripts-9.03.38/sysconfig.txt" but I realized that rule6-* information is missing besides the fact, that I can use it according this information: http://rhn.redhat.com/errata/RHBA-2012-0355.html

So please document rule6-* avaliability inside sysconfig.txt documentation file. 

Version-Release number of selected component (if applicable):
initscripts-9.03.38-1.el6


Actual results:
documentation about rule6-* is missing

Expected results:
rule6-* possibility should be documented


thank you
Comment 1 Lukáš Nykrýn 2013-03-14 06:55:12 EDT
 /etc/sysconfig/network-scripts/rule-<interface-name>
+/etc/sysconfig/network-scripts/rule6-<interface-name>
 
   Contains lines that specify additional routing rules that should be added
   when the associated interface is brought up.
 
-  Each non-comment line is used directly as an argument to "/sbin/ip rule add".
+  Each non-comment line is used directly as an argument to "/sbin/ip rule add"
+  or "/sbin/ip -6 rule add" for rule6 files.

Is such change sufficient?
Comment 2 Michal Bruncko 2013-03-14 09:05:24 EDT
yes, this is fine, it makes rule6-* documented. But I personally prefer to differentiate between different configuration files like for other config files in following way: 
- keep original rule-* configuration documentation unchanged
- just append at the end of file something like this:

<snip>
/etc/sysconfig/network-scripts/rule6-<interface-name>

  Contains lines that specify additional IPv6 routing rules that should be added
  when the associated interface is brought up.

  Each non-comment line is used directly as an argument to "/sbin/ip -6 rule add".
</snip>

but in real it does not matter. I just wanted to have rule6-* in documentation. Its your choice :)

And thank you for taking this report over.
Comment 3 Lukáš Nykrýn 2013-04-02 10:29:15 EDT
Upstream commit bd80c85bc077753f7bef74c38d85cab30c8831b0
Comment 11 errata-xmlrpc 2013-11-21 17:11:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1679.html

Note You need to log in before you can comment on or make changes to this bug.