Bug 92168 - Wrong app path for Ktoys because of up2date ktoys need to be in --prefix=/usr
Wrong app path for Ktoys because of up2date ktoys need to be in --prefix=/usr
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdetoys (Show other bugs)
9
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Ngo Than
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-03 11:29 EDT by Michael
Modified: 2007-03-27 00:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-12 12:00:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael 2003-06-03 11:29:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

Description of problem:
(redhat 9) Redhat update agent does not update (Ktoys ) correctly. I found out
that kweather is blank and other ktoys are missing. I have downloaded source
(3.0.2) and compiled with prefix of --prefix=/usr to fix this.  
READ ON PLEASE FOR THE BUG: 
 
 
Redhats update agent is the only source that has ktoys 3.0.3-3 <--(maybe no last
3) When you run it it overwrites(duh!) the previous version of ktoys. Again with
the wrong path. So it reinstalls  it without the prefix of --prefix=/usr. After
this upgrade ktoys are automatically broken.  

Version-Release number of selected component (if applicable):
3.0-3  

How reproducible:
Always

Steps to Reproduce:
reminder to staff before steps : affected ktoys & up2date
1.Compile an older source version 3.0.2 with --prefix=/usr works great.
2. Up2date sees you installed an older version and prompts for 3.0.3
3. You update it to that version and it break ktoys.                

(Likely because it misplaces them and does not put them  into /usr. (--prefix=/usr)
    

Actual Results:  
  * Kweater panel on kde3 toolbar is empty
  * Most of the toys including the mouse pointer toys are gone.

Expected Results:                                                              
* Kweather should have displayed weather on the panel
* Other toys should have not disappeared.

Additional info:


Everything has been explained above up2date is making a mistake :-) not me :-D I
rate this bug as high because it breaks part of the KDE3 desktop. A average 
user would be confused!
Comment 1 Adrian Likins 2003-06-11 15:51:22 EDT
Souns like a packaging bug in kdetoys, so reassaging to that component.
Comment 2 Ngo Than 2003-06-12 12:00:11 EDT
it's already fixed in kde-3.1.2, which you find in rawhide or on ftp.kde.org.
Comment 3 Michael 2003-07-02 01:10:55 EDT
Yes but up2date of kdetoys  needs to be stopped.  {eople are getting from
up2date the  bug version of ktoys!

Note You need to log in before you can comment on or make changes to this bug.