Bug 921758 - gcc internal error: "internal compiler error: in build_zero_init_1, at cp/init.c:279"
Summary: gcc internal error: "internal compiler error: in build_zero_init_1, at cp/ini...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc   
(Show other bugs)
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: Dagmar Prokopová
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-14 20:38 UTC by Adam Seering
Modified: 2014-07-01 22:54 UTC (History)
5 users (show)

Fixed In Version: gcc-4.4.7-4.el6
Doc Type: Bug Fix
Doc Text:
Previously, GCC could crash when compiling C++ code that contained a structure with va_list member field. The initialization of such structure has been fixed so now GCC doesn't crash anymore on such code.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 11:10:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1609 normal SHIPPED_LIVE gcc bug fix and enhancement update 2013-11-20 21:54:08 UTC

Description Adam Seering 2013-03-14 20:38:48 UTC
This is a request to pull in a bugfix from upstream.  The upstream bug is:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56403
Further detail is specified at the upstream bug report.

Description of problem:
When I compile an example program (code included in the upstream report), I get an internal gcc error:

"""
internal compiler error: in build_zero_init_1, at cp/init.c:279
"""

Along with a request to report the bug.


Version-Release number of selected component (if applicable):
RHEL 6.*
(Various versions of gcc from 4.2 through 4.7 are known to be affected.  See the upstream bug report.  gcc 4.4.5 on RHEL 6 has specifically been tested.)


How reproducible:
Always


Steps to Reproduce:
1. Attempt to compile the example code file included in the upstream bug report

  
Actual results:
gcc emits an internal error


Expected results:
gcc compiles the program.  (Or, alternatively but less preferably, gcc indicates that there's a code syntax error or some other input problem.)


Additional info:
This bug has been fixed upstream.  Details and discussion on the bug report in question.  The fix has been backported through gcc 4.6 already.  The fix appears to be a very simple one-line change.

Comment 2 Adam Seering 2013-04-17 19:01:30 UTC
Just checking back in:  Is there anything I can do to help with this bug?  What's the next step?

Comment 5 Dagmar Prokopová 2013-08-15 13:45:01 UTC
Verified for gcc-4.4.7-4.el6.

Comment 6 errata-xmlrpc 2013-11-21 11:10:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1609.html


Note You need to log in before you can comment on or make changes to this bug.