Bug 921831 - [abrt] libgpod-0.8.2-7.fc18: __strlen_sse2_pminub: Process /usr/lib/udev/iphone-set-info was killed by signal 11 (SIGSEGV)
Summary: [abrt] libgpod-0.8.2-7.fc18: __strlen_sse2_pminub: Process /usr/lib/udev/ipho...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libgpod
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5d5520a3032e3784cb16b0801f5...
: 955709 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-15 03:44 UTC by Pedro Andujar
Modified: 2013-09-22 23:59 UTC (History)
6 users (show)

Fixed In Version: libgpod-0.8.3-1.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-13 01:07:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (14.56 KB, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: build_ids (1.44 KB, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: cgroup (172 bytes, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: core_backtrace (533 bytes, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: dso_list (3.08 KB, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: environ (858 bytes, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: limits (1.29 KB, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: maps (15.37 KB, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: open_fds (175 bytes, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: proc_pid_status (901 bytes, text/plain)
2013-03-15 03:44 UTC, Pedro Andujar
no flags Details
File: smolt_data (2.69 KB, text/plain)
2013-03-15 03:45 UTC, Pedro Andujar
no flags Details
File: var_log_messages (332 bytes, text/plain)
2013-03-15 03:45 UTC, Pedro Andujar
no flags Details

Description Pedro Andujar 2013-03-15 03:44:25 UTC
Description of problem:
Just charging the iPhone battery.

Version-Release number of selected component:
libgpod-0.8.2-7.fc18

Additional info:
backtrace_rating: 4
cmdline:        /lib/udev/iphone-set-info
crash_function: __strlen_sse2_pminub
executable:     /usr/lib/udev/iphone-set-info
kernel:         3.8.1-201.fc18.x86_64
uid:            0

Truncated backtrace:
Thread no. 1 (4 frames)
 #0 __strlen_sse2_pminub at ../sysdeps/x86_64/multiarch/strlen-sse2-pminub.S:38
 #1 plist_get_string_val at /usr/src/debug/libplist-1.8/src/plist.c:541
 #2 read_sysinfo_extended_by_uuid at ipod-lockdown.c:81
 #3 write_sysinfo_extended at iphone-callout.c:15

Comment 1 Pedro Andujar 2013-03-15 03:44:30 UTC
Created attachment 710383 [details]
File: backtrace

Comment 2 Pedro Andujar 2013-03-15 03:44:34 UTC
Created attachment 710384 [details]
File: build_ids

Comment 3 Pedro Andujar 2013-03-15 03:44:36 UTC
Created attachment 710385 [details]
File: cgroup

Comment 4 Pedro Andujar 2013-03-15 03:44:40 UTC
Created attachment 710386 [details]
File: core_backtrace

Comment 5 Pedro Andujar 2013-03-15 03:44:43 UTC
Created attachment 710387 [details]
File: dso_list

Comment 6 Pedro Andujar 2013-03-15 03:44:46 UTC
Created attachment 710388 [details]
File: environ

Comment 7 Pedro Andujar 2013-03-15 03:44:49 UTC
Created attachment 710389 [details]
File: limits

Comment 8 Pedro Andujar 2013-03-15 03:44:53 UTC
Created attachment 710390 [details]
File: maps

Comment 9 Pedro Andujar 2013-03-15 03:44:56 UTC
Created attachment 710391 [details]
File: open_fds

Comment 10 Pedro Andujar 2013-03-15 03:44:58 UTC
Created attachment 710392 [details]
File: proc_pid_status

Comment 11 Pedro Andujar 2013-03-15 03:45:01 UTC
Created attachment 710393 [details]
File: smolt_data

Comment 12 Pedro Andujar 2013-03-15 03:45:04 UTC
Created attachment 710394 [details]
File: var_log_messages

Comment 13 Christophe Fergeau 2013-07-09 16:11:14 UTC
Can you run 'ideviceinfo -x -k SerialNumber' from a terminal with your iPhone plugged and paste what appears on the terminal (feel free to replace the SerialNumber value with XXXXXX)? It's possible that it will return without displaying anything, in which case that's also useful info :)

Comment 14 Christophe Fergeau 2013-09-04 11:49:25 UTC
*** Bug 955709 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2013-09-04 12:31:57 UTC
libgpod-0.8.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libgpod-0.8.3-1.fc20

Comment 16 Fedora Update System 2013-09-04 12:42:41 UTC
libgpod-0.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libgpod-0.8.3-1.fc19

Comment 17 Fedora Update System 2013-09-04 12:56:18 UTC
libgpod-0.8.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libgpod-0.8.3-1.fc18

Comment 18 Fedora Update System 2013-09-05 01:32:20 UTC
Package libgpod-0.8.3-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgpod-0.8.3-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15789/libgpod-0.8.3-1.fc18
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2013-09-13 01:07:35 UTC
libgpod-0.8.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2013-09-13 01:09:06 UTC
libgpod-0.8.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-09-22 23:59:10 UTC
libgpod-0.8.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.