This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 921896 - Single quote in f19 release name breaks grub2, probably other stuff
Single quote in f19 release name breaks grub2, probably other stuff
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
19
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Alpha/F19AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-03-15 04:21 EDT by Adam Williamson
Modified: 2013-03-21 00:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 14:31:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-03-15 04:21:22 EDT
As discussed on devel:

https://lists.fedoraproject.org/pipermail/devel/2013-March/180239.html

the ' in "Schrödinger's Cat" has unfortunate consequences in grub2: it closes quotations in two lines of kernel config prematurely, breaking grub2 completely (the affected kernel entries are not visible in the menu, and any other kernel entries are visible but will fail to boot correctly).

It's quite possible / likely that this is the case in other things that parse the release name out of /etc/fedora-release etc too, really.

The immediate solution would probably be to replace it with a Unicode apostrophe, but hey, as notting said on IRC, if your proposed solution is 'MOAR UNICODE!' you might want to take a look in the mirror. Dumping it entirely would be ugly but safer.

The umlauted o could conceivably cause problems somewhere too, but I have not yet tested for sure whether it causes issues in grub.

Proposing as an Alpha blocker.
Comment 1 Adam Williamson 2013-03-15 04:23:52 EDT
I think grubby actually parses /etc/os-release , now I look at the code. But whatever we should do, we should probably do everywhere.
Comment 2 Jens Petersen 2013-03-18 04:52:24 EDT
> The umlauted o could conceivably cause problems somewhere too

The ö only renders correctly on the kernel console if /etc/fedora-release
is encoding in iso8859-1 instead of utf-8.  But changing the encoding would
likely mess up grub, etc instead, so I agree with the sentiment to
transliterate to ASCII.

Unless quoting ' works, maybe "Schroedingers Cat" is good enough?
(I will test more \' once a new f19 kernel lands.)


I think there need to be character restrictions for future release name suggestions...
Comment 3 Jaroslav Reznik 2013-03-18 11:17:27 EDT
(In reply to comment #2)
> > The umlauted o could conceivably cause problems somewhere too
> 
> The ö only renders correctly on the kernel console if /etc/fedora-release
> is encoding in iso8859-1 instead of utf-8.  But changing the encoding would
> likely mess up grub, etc instead, so I agree with the sentiment to
> transliterate to ASCII.
> 
> Unless quoting ' works, maybe "Schroedingers Cat" is good enough?
> (I will test more \' once a new f19 kernel lands.)

Works for me.

> 
> I think there need to be character restrictions for future release name
> suggestions...

On the other hand it would be great to make it working - instead of setting limitations for future names.
Comment 4 Adam Williamson 2013-03-18 12:00:38 EDT
Can we please paint the bikeshed that color *right now*? We have enough real bugs to deal with and having this one in the way is just complicating matters.
Comment 5 Jaroslav Reznik 2013-03-19 10:18:51 EDT
Well, I'm definitely in favour of release name tweak but if we do it now, then I'd like to stick with it for final too (not only for Alpha). Proposed "Schroedingers Cat" should work, we usually don't show it anywhere (correct me if I'm right).

Dennis?
Comment 6 Bill Nottingham 2013-03-19 12:38:27 EDT
Why would the ö only work if it's 8859-1? We switch the console to unicode very early in boot.

Personally, I'd just replace the ' with whatever the unicode quote equivalent is, and fix any weird quoting grub issues that way.
Comment 7 Adam Williamson 2013-03-19 14:06:36 EDT
jaro: it's shown in the bootloader menu for post-release update kernels - that's the whole bug here - and at the tty login prompt, at least. Probably other places.
Comment 8 Dennis Gilmore 2013-03-19 17:16:34 EDT
we have fixed up the ' today
Comment 9 Jaroslav Reznik 2013-03-20 06:30:17 EDT
(In reply to comment #7)
> jaro: it's shown in the bootloader menu for post-release update kernels -
> that's the whole bug here - and at the tty login prompt, at least. Probably
> other places.

Ah, sorry - I don't know what I was thinking about in time I wrote that comment :(
Comment 10 Adam Williamson 2013-03-20 12:40:08 EDT
Discussed at 2013-03-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-03-20/f19alpha-blocker-review-2.2013-03-20-16.00.log.txt . Accepted as a blocker per criterion https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Expected_installed_system_boot_behavior: "After firstboot is completed and on subsequent boots, a graphical install must boot to a log in screen where it is possible to log in to a working desktop as the user created during firstboot." - as soon as you apply a kernel update, system stops booting.
Comment 11 Adam Williamson 2013-03-20 13:08:55 EDT
The updated fedora-release is out already, I just need to test and verify it fixes the problem.
Comment 12 Christopher Patrick 2013-03-20 14:19:47 EDT
it fixes the problem for me upgraded 18 to 19 via yum and I got a working 19 system
Comment 13 Adam Williamson 2013-03-20 14:31:52 EDT
Thanks, Christopher.
Comment 14 Jens Petersen 2013-03-21 00:46:08 EDT
(In reply to comment #6)
> Why would the ö only work if it's 8859-1? We switch the console to unicode
> very early in boot.

Ok it seems to work after rebooting into fedora-release-19-0.5
- the console font seems to be a bit stateful...

> Personally, I'd just replace the ' with whatever the unicode quote
> equivalent is, and fix any weird quoting grub issues that way.

That renders as a box for me on the console but I can live with that for now.

Things look ok in grub now anyway.

Note You need to log in before you can comment on or make changes to this bug.