Bug 921932 - Update lessjs and expose for other Node.js modules
Update lessjs and expose for other Node.js modules
Status: CLOSED DUPLICATE of bug 921365
Product: Fedora
Classification: Fedora
Component: lessjs (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-15 05:57 EDT by Jamie Nguyen
Modified: 2013-03-15 19:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 06:15:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to upstream release 1.3.3 (2.04 MB, patch)
2013-03-15 05:59 EDT, Jamie Nguyen
no flags Details | Diff
Expose lessjs for other Node.js modules (1.77 KB, patch)
2013-03-15 06:01 EDT, Jamie Nguyen
no flags Details | Diff

  None (edit)
Description Jamie Nguyen 2013-03-15 05:57:53 EDT
Currently the lessjs package does not place anything in /usr/lib/node_modules so that other Node.js modules can make use of it.

I'm proposing two patches to the lessjs package which I will add in the comments below.

I would also like to offer to co-maintain lessjs. If you approve of the changes to the spec then I would be more than happy to lend a hand and apply them myself.

nodejs-jade (one of my packages) uses npm(less) in the %check section. It works and all tests pass when using the new lessjs package I have proposed.
Comment 1 Jamie Nguyen 2013-03-15 05:59:50 EDT
Created attachment 710531 [details]
Update to upstream release 1.3.3

This updates to 1.3.3 and removes three of the patches that are no longer required:
 - cssmin.js has been unbundled upstream
 - the dist/ folder is no longer included
 - the version number is now correct

I've also switched the source to use the npm tarball rather than the GitHub tarball.
Comment 2 Jamie Nguyen 2013-03-15 06:01:17 EDT
Created attachment 710532 [details]
Expose lessjs for other Node.js modules

This just adds the /usr/lib/node_modules/less folder with a package.json file and symlinks to the relevant places. This will allow require('less') to work in various Node.js modules.
Comment 3 Matthias Runge 2013-03-15 06:15:25 EDT

*** This bug has been marked as a duplicate of bug 921365 ***
Comment 4 T.C. Hollingsworth 2013-03-15 19:39:26 EDT
Thanks, but we really should just move everything to %{nodejs_sitelib} and only have the browser verision in %{_datadir}.  I have everything mostly done locally already.

If you want to help out we need ycssmin in bug 921847 reviewed to finish everything up,

Note You need to log in before you can comment on or make changes to this bug.