Bug 921969 - rpmbuild should leave PKG_CONFIG_PATH alone
Summary: rpmbuild should leave PKG_CONFIG_PATH alone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm
Version: 6.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Marek Marusic
URL:
Whiteboard:
Depends On: 569773 921973
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-15 10:50 UTC by Florian Festi
Modified: 2015-07-22 07:02 UTC (History)
7 users (show)

Fixed In Version: rpm-4.8.0-40.el6
Doc Type: Bug Fix
Doc Text:
If a Perl script in a package contained a string declared as a here-document that included the "use" or "require" words, or a multiline string with these words, the package in some cases had incorrect dependencies when it was created using the "rpmbuild" command. Now, the "use" and "require" strings are ignored as keywords in here-documents and multiline strings, which prevents the problem from occurring.
Clone Of: 569773
: 1193328 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:02:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1452 normal SHIPPED_LIVE rpm bug fix and enhancement update 2015-07-20 18:43:47 UTC

Description Florian Festi 2013-03-15 10:50:07 UTC
Fix available upstream.


+++ This bug was initially created as a clone of Bug #569773 +++

Description of problem:
If you want to build a package which is depended on another package, and detects it with pkgconfig it won't get detected if this other package is in a non standard path (which was set in PKG_CONFIG_PATH)
The patch from bug 212522 creates this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=212522

Version-Release number of selected component (if applicable):
4.4.2.3-18

How reproducible:

Steps to Reproduce:
1. install/build something with another prefix path (for example /usr/broken), with a pkgconfig file, like eventlog: http://www.balabit.com/downloads/files/eventlog/0.2/
2. set PKG_CONFIG_PATH to the prefix path from step 1
3. build something with rpmbuild which detects in it's configure where the package from step 1 is located, like syslog-ng: http://www.balabit.com/downloads/files/syslog-ng/
  
Actual results:
pkgconfig reports the package is not found, this works when building from commandline, or with all rpm(build) packages before 4.4.2.3-18

Expected results:
pkgconfig should find the package.

Additional info:
The PKG_CONFIG_PATH is actually set by another package we build.

Proposed fix:
Modify the patch form the other the bug mentioned above so it does not overwrite the PKG_CONFIG_PATH but extends it.

Comment 1 RHEL Product and Program Management 2013-07-25 21:09:54 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 5 RHEL Product and Program Management 2013-10-14 04:06:29 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 8 Marek Marusic 2015-02-06 08:16:53 UTC
Hello,

is this bug fixed for RHEL7 alredy ?

Comment 9 Marek Marusic 2015-02-17 07:45:27 UTC
This bug is present also on RHEL7, I reported this in BZ #1193328

Comment 13 errata-xmlrpc 2015-07-22 07:02:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1452.html


Note You need to log in before you can comment on or make changes to this bug.