Bug 922021 - [abrt] coreutils-8.15-9.fc17: keycompare_mb: Process /usr/bin/sort was killed by signal 11 (SIGSEGV)
Summary: [abrt] coreutils-8.15-9.fc17: keycompare_mb: Process /usr/bin/sort was killed...
Status: CLOSED DUPLICATE of bug 902917
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f8ff689118fd497fab42620d952...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-15 12:15 UTC by Matt Hooper
Modified: 2013-03-15 14:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 14:38:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.96 KB, text/plain)
2013-03-15 12:15 UTC, Matt Hooper
no flags Details
File: build_ids (164 bytes, text/plain)
2013-03-15 12:15 UTC, Matt Hooper
no flags Details
File: cgroup (126 bytes, text/plain)
2013-03-15 12:15 UTC, Matt Hooper
no flags Details
File: core_backtrace (611 bytes, text/plain)
2013-03-15 12:15 UTC, Matt Hooper
no flags Details
File: dso_list (492 bytes, text/plain)
2013-03-15 12:15 UTC, Matt Hooper
no flags Details
File: environ (3.33 KB, text/plain)
2013-03-15 12:15 UTC, Matt Hooper
no flags Details
File: limits (1.29 KB, text/plain)
2013-03-15 12:16 UTC, Matt Hooper
no flags Details
File: maps (2.16 KB, text/plain)
2013-03-15 12:16 UTC, Matt Hooper
no flags Details
File: open_fds (104 bytes, text/plain)
2013-03-15 12:16 UTC, Matt Hooper
no flags Details
File: proc_pid_status (913 bytes, text/plain)
2013-03-15 12:16 UTC, Matt Hooper
no flags Details
File: smolt_data (5.42 KB, text/plain)
2013-03-15 12:16 UTC, Matt Hooper
no flags Details
File: var_log_messages (1.73 KB, text/plain)
2013-03-15 12:16 UTC, Matt Hooper
no flags Details

Description Matt Hooper 2013-03-15 12:15:39 UTC
Description of problem:
Testing https://bugzilla.novell.com/show_bug.cgi?id=798538

$ perl -e 'print "1","A"x50000000,"\r\n\r\n"' | sort -d
Segmentation fault (core dumped)

$ rpm -q coreutils
coreutils-8.15-9.fc17.x86_64


Version-Release number of selected component:
coreutils-8.15-9.fc17

Additional info:
backtrace_rating: 4
cmdline:        sort -d
crash_function: keycompare_mb
executable:     /usr/bin/sort
kernel:         3.7.3-101.fc17.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 keycompare_mb at sort.c:3213
 #1 compare at sort.c:3278
 #2 mergelines_node at sort.c:4006
 #3 merge_loop at sort.c:4091
 #4 sortlines at sort.c:4208
 #5 sort at sort.c:4481

Potential duplicate: bug 902917

Comment 1 Matt Hooper 2013-03-15 12:15:44 UTC
Created attachment 710618 [details]
File: backtrace

Comment 2 Matt Hooper 2013-03-15 12:15:46 UTC
Created attachment 710619 [details]
File: build_ids

Comment 3 Matt Hooper 2013-03-15 12:15:49 UTC
Created attachment 710620 [details]
File: cgroup

Comment 4 Matt Hooper 2013-03-15 12:15:52 UTC
Created attachment 710621 [details]
File: core_backtrace

Comment 5 Matt Hooper 2013-03-15 12:15:55 UTC
Created attachment 710622 [details]
File: dso_list

Comment 6 Matt Hooper 2013-03-15 12:15:57 UTC
Created attachment 710623 [details]
File: environ

Comment 7 Matt Hooper 2013-03-15 12:16:00 UTC
Created attachment 710624 [details]
File: limits

Comment 8 Matt Hooper 2013-03-15 12:16:02 UTC
Created attachment 710625 [details]
File: maps

Comment 9 Matt Hooper 2013-03-15 12:16:04 UTC
Created attachment 710626 [details]
File: open_fds

Comment 10 Matt Hooper 2013-03-15 12:16:07 UTC
Created attachment 710627 [details]
File: proc_pid_status

Comment 11 Matt Hooper 2013-03-15 12:16:12 UTC
Created attachment 710628 [details]
File: smolt_data

Comment 12 Matt Hooper 2013-03-15 12:16:16 UTC
Created attachment 710629 [details]
File: var_log_messages

Comment 13 Ondrej Vasik 2013-03-15 14:38:45 UTC
I believe you should update your system, this was already fixed by  coreutils-8.15-10.fc17 (Released Feb 1st) - https://bugzilla.redhat.com/show_bug.cgi?id=902917 . Closing duplicate.

*** This bug has been marked as a duplicate of bug 902917 ***


Note You need to log in before you can comment on or make changes to this bug.