Bug 922025 - [abrt] coreutils-8.15-9.fc17: different_multi: Process /usr/bin/uniq was killed by signal 11 (SIGSEGV)
[abrt] coreutils-8.15-9.fc17: different_multi: Process /usr/bin/uniq was kill...
Status: CLOSED DUPLICATE of bug 902917
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
abrt_hash:9ba38693068905d711c4e5638b8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-15 08:25 EDT by Matt Hooper
Modified: 2013-03-15 10:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 10:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (10.33 KB, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: cgroup (126 bytes, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: core_backtrace (401 bytes, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: dso_list (408 bytes, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: environ (3.27 KB, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: limits (1.29 KB, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: maps (1.67 KB, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: open_fds (104 bytes, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: proc_pid_status (919 bytes, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: smolt_data (5.42 KB, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details
File: var_log_messages (304 bytes, text/plain)
2013-03-15 08:25 EDT, Matt Hooper
no flags Details

  None (edit)
Description Matt Hooper 2013-03-15 08:25:21 EDT
Description of problem:
Testing https://bugzilla.novell.com/show_bug.cgi?id=796243

$ perl -e 'print "1","A"x50000000,"\r\n\r\n"' | uniq
AAAA....
Segmentation fault (core dumped)

$ rpm -q coreutils
coreutils-8.15-9.fc17.x86_64

Version-Release number of selected component:
coreutils-8.15-9.fc17

Additional info:
backtrace_rating: 4
cmdline:        uniq
crash_function: different_multi
executable:     /usr/bin/uniq
kernel:         3.7.3-101.fc17.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #0 different_multi at uniq.c:397
 #1 check_file at uniq.c:515

Potential duplicate: bug 734335
Comment 1 Matt Hooper 2013-03-15 08:25:24 EDT
Created attachment 710632 [details]
File: backtrace
Comment 2 Matt Hooper 2013-03-15 08:25:26 EDT
Created attachment 710633 [details]
File: cgroup
Comment 3 Matt Hooper 2013-03-15 08:25:28 EDT
Created attachment 710634 [details]
File: core_backtrace
Comment 4 Matt Hooper 2013-03-15 08:25:30 EDT
Created attachment 710635 [details]
File: dso_list
Comment 5 Matt Hooper 2013-03-15 08:25:32 EDT
Created attachment 710636 [details]
File: environ
Comment 6 Matt Hooper 2013-03-15 08:25:34 EDT
Created attachment 710637 [details]
File: limits
Comment 7 Matt Hooper 2013-03-15 08:25:37 EDT
Created attachment 710638 [details]
File: maps
Comment 8 Matt Hooper 2013-03-15 08:25:40 EDT
Created attachment 710639 [details]
File: open_fds
Comment 9 Matt Hooper 2013-03-15 08:25:43 EDT
Created attachment 710640 [details]
File: proc_pid_status
Comment 10 Matt Hooper 2013-03-15 08:25:46 EDT
Created attachment 710641 [details]
File: smolt_data
Comment 11 Matt Hooper 2013-03-15 08:25:49 EDT
Created attachment 710642 [details]
File: var_log_messages
Comment 12 Ondrej Vasik 2013-03-15 10:41:17 EDT
I believe you should update your system, this was already fixed by  coreutils-8.15-10.fc17 (Released Feb 1st) - https://bugzilla.redhat.com/show_bug.cgi?id=902917 . Closing duplicate.

*** This bug has been marked as a duplicate of bug 902917 ***

Note You need to log in before you can comment on or make changes to this bug.