Bug 922027 - [abrt] coreutils-8.15-9.fc17: keycmp: Process /usr/bin/join was killed by signal 11 (SIGSEGV)
[abrt] coreutils-8.15-9.fc17: keycmp: Process /usr/bin/join was killed by sig...
Status: CLOSED DUPLICATE of bug 902917
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
abrt_hash:c2b3f41db38dd85843b36495c42...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-15 08:30 EDT by Matt Hooper
Modified: 2013-03-15 10:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 10:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (14.16 KB, text/plain)
2013-03-15 08:30 EDT, Matt Hooper
no flags Details
File: cgroup (126 bytes, text/plain)
2013-03-15 08:30 EDT, Matt Hooper
no flags Details
File: core_backtrace (401 bytes, text/plain)
2013-03-15 08:30 EDT, Matt Hooper
no flags Details
File: dso_list (408 bytes, text/plain)
2013-03-15 08:30 EDT, Matt Hooper
no flags Details
File: environ (3.27 KB, text/plain)
2013-03-15 08:30 EDT, Matt Hooper
no flags Details
File: limits (1.29 KB, text/plain)
2013-03-15 08:31 EDT, Matt Hooper
no flags Details
File: maps (1.77 KB, text/plain)
2013-03-15 08:31 EDT, Matt Hooper
no flags Details
File: open_fds (195 bytes, text/plain)
2013-03-15 08:31 EDT, Matt Hooper
no flags Details
File: proc_pid_status (913 bytes, text/plain)
2013-03-15 08:31 EDT, Matt Hooper
no flags Details
File: smolt_data (5.42 KB, text/plain)
2013-03-15 08:31 EDT, Matt Hooper
no flags Details
File: var_log_messages (305 bytes, text/plain)
2013-03-15 08:31 EDT, Matt Hooper
no flags Details

  None (edit)
Description Matt Hooper 2013-03-15 08:30:46 EDT
Description of problem:
Testing https://bugzilla.novell.com/show_bug.cgi?id=798541

$ perl -e 'print "1","A"x50000000,"\r\n\r\n"' > /tmp/test.txt
$ join -i /tmp/test.txt /tmp/test.txt
Segmentation fault (core dumped)

$ rpm -q coreutils
coreutils-8.15-9.fc17.x86_64

Version-Release number of selected component:
coreutils-8.15-9.fc17

Additional info:
backtrace_rating: 4
cmdline:        join -i /tmp/test.txt /tmp/test.txt
crash_function: keycmp
executable:     /usr/bin/join
kernel:         3.7.3-101.fc17.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (2 frames)
 #0 keycmp at join.c:527
 #1 system_join at join.c:913
Comment 1 Matt Hooper 2013-03-15 08:30:50 EDT
Created attachment 710644 [details]
File: backtrace
Comment 2 Matt Hooper 2013-03-15 08:30:52 EDT
Created attachment 710645 [details]
File: cgroup
Comment 3 Matt Hooper 2013-03-15 08:30:54 EDT
Created attachment 710646 [details]
File: core_backtrace
Comment 4 Matt Hooper 2013-03-15 08:30:56 EDT
Created attachment 710647 [details]
File: dso_list
Comment 5 Matt Hooper 2013-03-15 08:30:58 EDT
Created attachment 710648 [details]
File: environ
Comment 6 Matt Hooper 2013-03-15 08:31:01 EDT
Created attachment 710649 [details]
File: limits
Comment 7 Matt Hooper 2013-03-15 08:31:03 EDT
Created attachment 710650 [details]
File: maps
Comment 8 Matt Hooper 2013-03-15 08:31:05 EDT
Created attachment 710651 [details]
File: open_fds
Comment 9 Matt Hooper 2013-03-15 08:31:08 EDT
Created attachment 710652 [details]
File: proc_pid_status
Comment 10 Matt Hooper 2013-03-15 08:31:10 EDT
Created attachment 710653 [details]
File: smolt_data
Comment 11 Matt Hooper 2013-03-15 08:31:13 EDT
Created attachment 710654 [details]
File: var_log_messages
Comment 12 Ondrej Vasik 2013-03-15 10:40:43 EDT
I believe you should update your system, this was already fixed by  coreutils-8.15-10.fc17 (Released Feb 1st) - https://bugzilla.redhat.com/show_bug.cgi?id=902917 . Closing duplicate.

*** This bug has been marked as a duplicate of bug 902917 ***

Note You need to log in before you can comment on or make changes to this bug.