Bug 92209 - Kickstart keeps wiping partitions on unspecified drives
Kickstart keeps wiping partitions on unspecified drives
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-03 17:12 EDT by redhat8
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 15:03:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description redhat8 2003-06-03 17:12:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020920
Netscape/7.0

Description of problem:
My situation:
I have PC's with 1 internal IDE hard drive w/Windows 2000 and 1 external SCSI
hard drive used for RH.  These are machines at my work which we want to set up
for dual-booting.  The idea is to install RH on the external SCSI using
kickstart and not touch a thing on the internal IDE drive (no bootloader
installed since we plan to use Windows bootloader).

The problem:
When kickstarting RH8, all the partitions on the internal IDE drive get wiped
out, thus killing off Win2K.  However, when kickstarting RH9, everything works
perfect - RH get loaded, Win2K stays intact.  I have both configuration files
setup the same way (except for indiviual packages).  Here is a quick snip of the
relevant lines from the config:

<snip>
bootloader --location=partition
#zerombr
clearpart --drives sda --initlabel
part / --fstype ext2 --size=4096 --ondisk=sda
part swap --size=1024 --ondisk=sda
part /var --fstype ext2 --size=100 --grow --ondisk=sda
</snip>

As you can see, the clearpart and part commands always specify the SCSI device.
 But the IDE partitions get wiped out as well under RH8.  Again, RH9 works fine.
 I have not tried other versions. Also, I have tried both  "clearpart
--drives=sda" and "clearpart --drives sda" with same result. 

So, you say, "why don't you use RH9?".  Unforunately, RH8 is the current
requirement.  Please help!  Thanks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.setup kickstart to load RH8 on secondary device
2.
3.
    

Additional info:
Comment 1 Michael Fulbright 2003-06-10 15:03:13 EDT
This is fixed in RHL 9. We do not in general backport fixes to previous RHL 
releases.

Note You need to log in before you can comment on or make changes to this bug.