Bug 92236 - Errata replaces /etc/pam.d/cups
Errata replaces /etc/pam.d/cups
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-03 20:58 EDT by Andrew Bartlett
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: 1.1.19-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 11:30:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2003-06-03 20:58:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

Description of problem:
Upon upgrade to this errata package, my customisations to /etc/pam.d/cups (to
use system-auth, in my case) were overwritten.

Version-Release number of selected component (if applicable):
cups-1.1.17-0.7

How reproducible:
Always

Steps to Reproduce:
1. Modify /etc/pam.d/cups
2. Upgrade to errata package
3. Login to web interface
    

Actual Results:  Logins to accounts in LDAP fail

Expected Results:  Logins proceed as before

Additional info:

RedHat *should* use system-auth for this component, but as a much more urgent
issue, it *must* not overwrite configuration file changes!

Administrators need to be able to upgrade to errata packages without it causing
massive disruption to their site's operations...
Comment 1 Tim Waugh 2003-06-10 11:30:48 EDT
Thanks.  Marked as %config(noreplace) in 1.1.19-5.

Note You need to log in before you can comment on or make changes to this bug.