Bug 92243 - cross (Build)Requires to xemacs-sumo
Summary: cross (Build)Requires to xemacs-sumo
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xemacs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-04 02:28 UTC by Takanori MATSUURA
Modified: 2015-01-08 00:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 02:21:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Takanori MATSUURA 2003-06-04 02:28:52 UTC
Description of problem:
In the spec file of xemacs
  BuildRequires: xemacs-sumo >= 20030414
is set.

While in the spec file of xemacs-sumo
  BuildRequires: xemacs
is set.

I think BuildRequires in xemacs is not needed.

Version-Release number of selected component (if applicable):
xemacs-21.4.13-2

How reproducible:
Always

Steps to Reproduce:
1. check xemacs.spec

Comment 1 Takanori MATSUURA 2003-06-04 09:36:36 UTC
Also
  Requires: xemacs-sumo >= 20030414
is not needed.

Comment 2 Jens Petersen 2003-06-04 11:31:33 UTC
Thanks for your report.  Regarding comment 1, it may be true but
I would say xemacs is effectively useless with xemacs-sumo installed.
If you really want to install it without xemacs-sumo you can do so
with the rpm options --nodeps.

I haven't tested building xemacs without xemacs-sumo, but will look into
that.  Not having xemacs-sumo installed might cause problems in our
build system too.

Comment 3 Takanori MATSUURA 2003-06-04 13:22:10 UTC
According to README.packages
  Q. Do I need to have the packages to compile XEmacs?

  A. Theoretically, no -- XEmacs will build and install just fine without any
     packages installed.  However, only the most basic editing functions will
     be available with no packages installed, so installing packages is an
     essential part of making your installed XEmacs _useful_.
So I suppose xemacs-sumo is not required by the build stage of xemacs.

For minimum-install users, requirement of xemacs-sumo should be deleted. :-)

Comment 4 Jens Petersen 2003-09-08 02:21:27 UTC
Actually I just realised that xemacs-sumo is required currently to build xemacs,
since some locale-related X resource files from mule-packages are included during
packaging.



Note You need to log in before you can comment on or make changes to this bug.